1. gregs87's Avatar
    New here....BB for years but am test driving the iphone 4...I have the device almost a week, but battery life is only OK. My question is could I have a bum battery because when I go to settings-general-usage, there is no info. Says times will be shown after phone is fully charged. I have charged it every day since I have had it and still see that message.

    Another question, when I go to network settings, the personal hotspot thing is "spinning" and then it shows the set up option. I dont have personal hotspot, yet I have no option to turn it on or off...is that normal.

    Thanks.

    Edit: battery was 100% at 7:30 this morning. It is now 3:00 pm and with normal to maybe less than normal usage it is at 69%...dont think that should be from what I have read on here.
    Last edited by gregs87; 08-10-2011 at 03:08 PM.
    08-10-2011 03:06 PM
  2. jsntrenkler's Avatar
    Spinning on personal hotspot is normal if you don't subscribe. Spinning went away right after I signed up for it. Try hard reseting your iPhone hold down the power button and home button until you see the Apple logo, that may help with your usage counter problem.
    08-10-2011 03:08 PM
  3. gregs87's Avatar
    I did that a couple times already....

    Thanks for the hotspot answer...
    08-10-2011 03:09 PM
  4. Alli's Avatar

    Edit: battery was 100% at 7:30 this morning. It is now 3:00 pm and with normal to maybe less than normal usage it is at 69%...dont think that should be from what I have read on here.
    That's excellent battery life. That means that even if you start using it more heavily, it will still get you through into the evening without a charge.
    08-10-2011 03:29 PM
  5. Fausty82's Avatar
    I did that a couple times already....

    Thanks for the hotspot answer...
    The hard reset function clears the usage stats on your phone. After a full charge, the stats are reset to 0:00 usage and 0:00 standby... as time passes the standby time counts up... as does the usage whenever you are actually and actively using the phone or an app... but if you do a hard reset (power and home buttons until you see the Apple logo), those counters get cleared and the fields are "empty". The only way around it is to fully charge the phone and then NOT do the hard reset.

    Are you jailbroken? If so, anything that causes a respring of the interface/winterboard will also cause the usage stat fields to clear.
    08-10-2011 03:45 PM
  6. gregs87's Avatar
    Not Jailbroken. Haven't done a hard reset (didn't know how) but I will do that this evening before I start it to charge and see if anything changes tomorrow. Thanks to all.
    08-10-2011 04:23 PM
LINK TO POST COPIED TO CLIPBOARD