1. PsYcHoNeWb's Avatar
    Has anyone noticed that with the iPhone 4, pretty sure only the Verizon version that some text messages say they are sent, but never are received by the person that you are sending them too?

    Had this phone for about 2 months now and while it is a great phone this leads me to believe that it is more a Verizon network issue rather than a hardware issue. Anyone else experience this bug? The one thing that I notice is that when it takes longer than normal to send a text message it usually isn't received by the other person. Not a huge problem, happens maybe 2-3 times a week.
    07-24-2011 01:26 PM
  2. iPhoneGleek's Avatar
    That might just be verizion.
    07-24-2011 01:32 PM
  3. Dermot_McCann's Avatar
    Yeah, it must be verizion.
    07-24-2011 01:49 PM
  4. Adawg1203's Avatar
    Has anyone noticed that with the iPhone 4, pretty sure only the Verizon version that some text messages say they are sent, but never are received by the person that you are sending them too?

    Had this phone for about 2 months now and while it is a great phone this leads me to believe that it is more a Verizon network issue rather than a hardware issue. Anyone else experience this bug? The one thing that I notice is that when it takes longer than normal to send a text message it usually isn't received by the other person. Not a huge problem, happens maybe 2-3 times a week.
    During high traffic hours the network latency will increase but, messages are stored in the network first before being sent to the receiver. Hence, if the receiver has there phone turned off for several days they will still get the message as soon as there phone is registered back onto the network.

    To experience non delivery of messages 2-3 times a week is definitely abnormal. I would have the phone's software checked (Apple store) but specifically, the SMS app. Its easy to think that this is a network problem however, the VZ network is not built to respond this way.

    For what it's worth have the phone checked out and call VZ technical support as well.

    Hope this will help.
    07-24-2011 06:52 PM
  5. PsYcHoNeWb's Avatar
    During high traffic hours the network latency will increase but, messages are stored in the network first before being sent to the receiver. Hence, if the receiver has there phone turned off for several days they will still get the message as soon as there phone is registered back onto the network.

    To experience non delivery of messages 2-3 times a week is definitely abnormal. I would have the phone's software checked (Apple store) but specifically, the SMS app. Its easy to think that this is a network problem however, the VZ network is not built to respond this way.

    For what it's worth have the phone checked out and call VZ technical support as well.

    Hope this will help.
    It does help and I appreciate any help. I went on the Verizon forums too and apparently I am not the only one having this issue. In all honesty it isn't a big deal at all, really doesn't bother me but just thought I would get someone opinion. The funny thing is is when I was jailbroken on 4.2.8 and used biteSMS, same issue as stock SMS on pure iOS.
    07-26-2011 08:12 AM
  6. Adawg1203's Avatar
    It does help and I appreciate any help. I went on the Verizon forums too and apparently I am not the only one having this issue. In all honesty it isn't a big deal at all, really doesn't bother me but just thought I would get someone opinion. The funny thing is is when I was jailbroken on 4.2.8 and used biteSMS, same issue as stock SMS on pure iOS.
    Wow. Now that is strange. If you ever figure out the issue please, let us all know.

    Best of luck!
    07-26-2011 04:02 PM
  7. kch50428's Avatar
    You need to call Verizon Customer Service and get routed to tech support from a phone other than your iPhone - and they'll go through some troubleshooting with you - including trying to send texts while they monitor their back-end system and see what, if any error messages they might be seeing... it could be that there is a configuration SNAFU in their back-end systems, and they'll have to basically delete your phone form the system and put it back in again to clear it up... this is not something that happens frequently, but it does indeed happen.
    07-26-2011 04:20 PM
  8. PsYcHoNeWb's Avatar
    You need to call Verizon Customer Service and get routed to tech support from a phone other than your iPhone - and they'll go through some troubleshooting with you - including trying to send texts while they monitor their back-end system and see what, if any error messages they might be seeing... it could be that there is a configuration SNAFU in their back-end systems, and they'll have to basically delete your phone form the system and put it back in again to clear it up... this is not something that happens frequently, but it does indeed happen.
    Thanks, might go ahead and try that when I get back from vacation and let everyone know how it turns out.
    07-26-2011 05:01 PM
  9. Cyder's Avatar
    No but my home button seems to take a couple pushes before being able to exit an app or reset back to the homescreen. I'll chalk it up to lag and wait for the 5 to come out.
    07-29-2011 10:46 AM
  10. Eileen89's Avatar
    I have the same issue with AT&T. Some of my text messages go through while others don't.


    Sent from my iPhone 4 using Tapatalk.
    07-29-2011 02:40 PM
  11. RemmyZero's Avatar
    i was having this issue for many months on my iPhone and android phones on big red. i had an iphone in early april, returned it and had another in early june and returned it. in between those times i've had a thunderbolt, droid-x, droid incredible 2 and a blackberry storm 2 and i had the same issue on every phone. in most cases the message would get bounced back as "could not be delivered" and would refuse to send no matter how many times i tried to resend them. i was sending about 5000 texts a month and maybe every 1 out of 5 would fail, so this was extremely aggravating.

    i called vzw maybe 5 times over the issue and each time they would "tweak" some setting in their database/system/whatever but the issue never was resolved. finally within the past month it has basically gone away and everything works as it should. i am still using a droid-x but either getting another iphone 4 next week or holding out for the iP5.

    bottom line is that it's definitely a vzw issue.
    08-03-2011 09:50 AM
LINK TO POST COPIED TO CLIPBOARD