1. iaddict_'s Avatar
    I purchased five books from iBooks as I was going on a vacation and wanted to be able to read them during the trip. Unfortunately I should have first downloaded a sample before making my purchases.

    I attached two screen shots of the issues I'm having. It seems that I'm having these issues with every book I have purchased in iBooks so it's not just one book. And I do not think the epub files are corrupted. I have tried uninstalling iBooks, downloaded the books again on my phone, and even deleting the books and then downloading them again in iTunes and synching them over again.

    Just now I restored my phone and tested the books without having jailbreak and it worked fine. Then I jailbroke my phone with Redsn0w and got the same issue as before. And I even restored and jailbroke with jailbreakme.com and again I'm having the same issue. So obviously the issue only arises with jailbroken iPhones.

    Is there a way to fix this issue? And is anyone else experiencing the same problem as me?

    It's becoming very frustrating as I could have purchased these books from Kobo and ripped the DRM and just read them that way as I have done that in the past and it works perfectly even with a jailbroken iPhone.

    I'd appreciate any advice at all.

    Thanks in advance.
    07-06-2011 07:49 PM
  2. Eileen89's Avatar
    Yes, I was having the same problem as you after jailbreaking my iPad 2 today. The only fix that worked for me was to go to Cydia, Sources, (hit edit) and add the following repo: insanelyi Repository - insanelyi. Then go to search and type in "iBooksFix". Once you install that app, reboot you iPhone and you shouldn't receive anymore messages like that....
    07-06-2011 08:42 PM
  3. iRooney's Avatar
    Be careful posting that repo. Someone might want to throw that up on a more reputable one.
    07-06-2011 08:49 PM
  4. Eileen89's Avatar
    Be careful posting that repo. Someone might want to throw that up on a more reputable one.
    Is there another one that will work better? This one was the only one that I found this afternoon while doing a Google search to fix this problem. Thanks.
    07-06-2011 08:56 PM
  5. iaddict_'s Avatar
    Thanks for the tip.

    I just tried it and rebooted numerous times but I'm still getting the same results.

    Thanks anyways, I guess I'll just have to try my best to read it the way it is unless I can find a fix.
    07-06-2011 10:20 PM
  6. xxDruMMer BoYxx's Avatar
    That first image is what happened to me on a book I have. All I did was close the book and reopen it.
    07-09-2011 02:32 AM
  7. jeans94621's Avatar
    Action menu is causing the problem. You have to remove that and anything that adds it. Then your ibooks will be fine.
    07-09-2011 08:13 AM
LINK TO POST COPIED TO CLIPBOARD