1. asuprice's Avatar
    Any Bug fixes? Performance Improvements?
    05-04-2011 02:09 PM
  2. mi_canuck#IM's Avatar
    05-04-2011 03:23 PM
  3. iphonehelper's Avatar
    i need download link for ios 4.2.8..
    05-04-2011 04:45 PM
  4. rayz336's Avatar
    plug your iPhone in and then hit check for updates on the device panel
    05-04-2011 09:52 PM
  5. P@t's Avatar
    downloading now. any other improvements or just damage control for the locationgate?
    05-05-2011 12:13 AM
  6. DonNguyen#IM's Avatar
    seems like it's just damage control for locationgate
    05-05-2011 12:48 AM
  7. rdrum's Avatar
    I upgraded to 4.2.8 last night and have not noticed any differences at all.
    05-05-2011 09:07 AM
  8. PlainEnvelopes's Avatar
    I just upgraded and now I cant open my apps. It starts to open them then just goes back to the home screen. Anyone know how to fix this?
    05-06-2011 08:04 PM
  9. imandroid's Avatar
    seems like it's just damage control for locationgate
    Damn man glad to see you over here you finally bounced from the Berry.
    05-06-2011 09:35 PM
  10. phreddyl's Avatar
    I just upgraded and now I cant open my apps. It starts to open them then just goes back to the home screen. Anyone know how to fix this?
    Yeah go to app store and download any random free app. This fixes the problem. Not sure why. But it works.
    05-06-2011 09:49 PM
  11. PlainEnvelopes's Avatar
    Yeah go to app store and download any random free app. This fixes the problem. Not sure why. But it works.
    yeah that did it. thanks man.
    05-06-2011 10:19 PM
  12. Lylej2k's Avatar
    Damn man glad to see you over here you finally bounced from the Berry.
    I see alot of familiar screen names here that used to be over at CB.

    Back on topic, I'll upgrade once a JB is available. As usual.
    05-07-2011 07:40 PM
  13. kch50428's Avatar
    Back on topic, I'll upgrade once a JB is available. As usual.
    sn0wbreeze is untethered for 4.2.8 - works dandy.
    05-07-2011 07:43 PM
  14. Lylej2k's Avatar
    sn0wbreeze is untethered for 4.2.8 - works dandy.
    Don't know how I missed it! Thanks for the heads up!
    05-09-2011 05:46 PM
  15. rustymini's Avatar
    Hello, I'm new to these forums,and am currently an Android user(EVO 4g),and am thinking of getting an iPhone at the end of my contract. One of my most important questions is: Does every iPhone get an update no matter with generation it is examples, 3g,3gs,etc? The reason I'm asking is because with Android phones the older(more than 1 yr old)they are they get no more updates(froyo,gingerbread,etc)because they want you to buy another expensive phone every 1 or 2 years. I understand that's how they make money,but it's wrong. I've heard that Apple keeps their phones up to date is this true? I shouldn't have to buy the EVO 3D just to have the latest updates-not if I can't or don't want to. Thanks to all that respond to my question! :o)
    06-06-2011 11:29 AM
  16. dmt316's Avatar
    Hello, I'm new to these forums,and am currently an Android user(EVO 4g),and am thinking of getting an iPhone at the end of my contract. One of my most important questions is: Does every iPhone get an update no matter with generation it is examples, 3g,3gs,etc? The reason I'm asking is because with Android phones the older(more than 1 yr old)they are they get no more updates(froyo,gingerbread,etc)because they want you to buy another expensive phone every 1 or 2 years. I understand that's how they make money,but it's wrong. I've heard that Apple keeps their phones up to date is this true? I shouldn't have to buy the EVO 3D just to have the latest updates-not if I can't or don't want to. Thanks to all that respond to my question! :o)
    The updates from Apple will get you through almost 2 years. But even after the 2 years you still have an awesome phone.
    06-06-2011 11:32 AM
  17. rustymini's Avatar
    The updates from Apple will get you through almost 2 years. But even after the 2 years you still have an awesome phone.
    Thanks for the info this helps a lot in making my decision.
    06-06-2011 12:33 PM
  18. dmt316's Avatar
    Thanks for the info this helps a lot in making my decision.
    no problem. not sure if you read all the wwdc news, but the 3gs, a 2 year old phone will be getting ios 5.
    06-07-2011 07:15 AM
  19. rustymini's Avatar
    no problem. not sure if you read all the wwdc news, but the 3gs, a 2 year old phone will be getting ios 5.
    I didn't know that. Thanks so much I'll keep reading and learning about the iPhone community.
    06-08-2011 11:25 AM
  20. Bugeyeblue's Avatar
    Are there any big differences between this new os and the os the phone originally had when verizon offered it? I'm still on the first verizon os, jailbroken, and don't know if it's worth going through the hassle of backing everything up, re-jailbreaking, setting up as new phone, and re-installing everything.
    06-11-2011 11:02 AM
  21. kagee#IM's Avatar
    I tried to update mine through itunes but it gave me an error saying "The iPhone could not be updated. This device isn't eligible for the requested build." Any suggestions? Thanks
    06-20-2011 05:32 PM
  22. dmt316's Avatar
    I tried to update mine through itunes but it gave me an error saying "The iPhone could not be updated. This device isn't eligible for the requested build." Any suggestions? Thanks
    The PRL gets updated with *228 send option 2. Not with iTunes
    06-20-2011 05:34 PM
  23. kagee#IM's Avatar
    The PRL gets updated with *228 send option 2. Not with iTunes
    i tried that and still will not update to version 4.2.8
    06-20-2011 05:43 PM
  24. dmt316's Avatar
    i tried that and still will not update to version 4.2.8
    4.2.8 is the version of iOS. Totally different from the PRL. PRL has to do with cell towers, iOS os the software of the phone.
    06-20-2011 05:46 PM
  25. kagee#IM's Avatar
    4.2.8 is the version of iOS. Totally different from the PRL. PRL has to do with cell towers, iOS os the software of the phone.
    Yes. I am having trouble installing the new iOS updated software to the phone. It tells me my device is not eligible for the requested build.
    06-20-2011 05:50 PM
32 12
LINK TO POST COPIED TO CLIPBOARD