1. Fausty82's Avatar
    Over the past couple of days I have noticed the battery life tanking. I am not aware of any changes except a few updates via Cydia of existing stuff... The really strange thing is when I check the usage (Settings > General > Usage) it shows the same value for Usage and Standby...

    Anybody else noticing that or have an idea why it's doing that all of a sudden? Still on iOS 4.2.1 JB.
    04-23-2011 09:27 PM
  2. newiphoneuser's Avatar
    If your usage time is same as standby that means your phone is "working" all the time. Probably a rogue process or something. Uninstall any new apps you may have installed or simply restore.
    04-24-2011 12:03 AM
  3. thenewmaster2012's Avatar
    Make sure all of the apps in your multitasking are closed!
    04-24-2011 02:48 PM
  4. Fausty82's Avatar
    Everything was closed... nothing showing in the switcher list... and the battery was draining fast... don't now what the rogue process was, but a hard reset fixed it... went all day today and still at 73% battery... it's all good today.
    04-24-2011 11:56 PM
  5. iquinn's Avatar
    Everything was closed... nothing showing in the switcher list... and the battery was draining fast... don't now what the rogue process was, but a hard reset fixed it... went all day today and still at 73% battery... it's all good today.
    I have been having this issue off and on since the first iOS 4.2 update. Not sure what the cause is but I have found that doing a synch seems to make it stop. Hope that a synch works for you as well.
    04-25-2011 12:02 AM
LINK TO POST COPIED TO CLIPBOARD