1. SHEDGES's Avatar
    I finally updated my iOS to on my i4 to 4.3.2. so I could downlaod Game Center. Update went fine and I have six apps that support Game Center. I launched the GC app and it asks for my USER ID and password which if I understand is my itunes log-in. Entered that info and hit "sign in". It tells me that USER ID hasn't been used in Game Center yet and to "create an account" (which makes sense). I entered the same info again and hit "create account".

    I enter the region I'm in (US) and my date of birth and it tells me the exact same thing again and sends me back to "create account". I went into itunes and changed my password (as one forum suggested) and I still get the same message. Any thoughts? Kind of a bummer since this is the main reason I updated. All the forums I'm reading indicate it should let me create an account, agree to the terms and conditions, create a nickname, etc. Frustrating to say the least.

    Thanks in advance,

    Scott H.
    04-23-2011 12:31 AM
  2. SHEDGES's Avatar
    Any thoughts on this? I changed my itunes password and I still get "This USER ID hasn't been used in Game Center. Please create a Game Center account" prompt.
    04-25-2011 04:18 PM
LINK TO POST COPIED TO CLIPBOARD