1. hahler2's Avatar
    Hi everyone. I'm having some problems with my iOS devices. I have an iPhone 4, and an iPad 3G. Both have been updated to the latest versions of the software. Both are getting significantly slower WiFi speeds than my iMac.

    I am running an Airport Extreme router. My iMac is consistently showing 22ms ping, 4.00 Mbps download, and .50 Mbps upload. However, both my iPhone and iPad are consistently giving me 222ms ping with 2.00 to 2.50 Mbps download and .50 upload.

    Anybody have any ideas on how to fix this? I've done some searching on the internet and found several ideas such as cranking up the screen brightness and resetting the network connections. Nothing has made a difference. Thanks for the help!
    04-16-2011 02:35 AM
  2. alpinestars1z's Avatar
    How far are you from the router?
    04-16-2011 03:42 PM
  3. hahler2's Avatar
    When I was running the tests last night I was about 5 feet from the router. Normally I am never greater than 30 to 35 feet away. I'm just wondering since my iMac works so well and my iOS devices don't if it's a setting in the router or something goofy like that.
    04-16-2011 06:27 PM
  4. FRAGMENT's Avatar
    i had the same problem after 4.1 upgrade. Got better latest one.
    04-18-2011 10:11 AM
  5. thenewmaster2012's Avatar
    Simple iOS Troubleshooting: Learn how to fix the iPhone, iPad and iPod Touch's most common technical issues and some tips to get the most out of your device" is a guide to the most common mishaps with iOS devices. Fix your iOS device yourself with this easy to follow step by step guide!

    ONLY $4.25 Order Now!
    Amazon.com: Simple iOS Troubleshooting: Learn how to fix the iPhone, iPad and iPod Touch's most common technical issues and some tips to get the most out of your device. eBook: JL M: Kindle Store

    or visit

    Home - Simple iOS Troubleshooting

    THANK YOU VERY MUCH FOR THE SUPPORT!!!
    04-24-2011 03:26 PM
LINK TO POST COPIED TO CLIPBOARD