1. poda521's Avatar
    Had a jailbroken 4.3.1 version.

    Tried restoring the phone but I can't even restore to the official 4.3.1. After trying to restore from iTunes, at the end it would just show the iTunes logo + USB plug.


    Any suggestions?
    04-06-2011 05:04 PM
  2. poda521's Avatar
    WTF? None of you guys can help?

    DFU doesn't solve it as every restore just brings me back to the "Connect to iTunes" screen. Phone doesn't show up in iTunes.

    Tried re-installing iTunes, that didn't help.
    Tried switching USB ports, that didn't help.
    Last thing left is to try and restore using 4.2.1.
    04-06-2011 06:11 PM
  3. WarrenRSV's Avatar
    I've got the same problem can anyone help please?
    04-06-2011 06:41 PM
  4. poda521's Avatar
    Restoring to 4.2.1 didn't do jack either.

    I'm having a hard enough time as it is to get this phone to the DFU screen again and I don't know why.

    Now I'm officially out of options other than traveling to an Apple Store
    04-06-2011 06:47 PM
  5. anon4705295's Avatar
    People probably aren't helping because (like me) they have no idea how to fix it, lol. I would take it to an Apple Store. They can probably fix it in-store and most likely won't charge you for the services.
    04-06-2011 07:32 PM
  6. BreakingKayfabe's Avatar
    Yeah. Trying to get it in DFU mode would be the last resort before taking it to an Apple
    store. If you can't even get to that then they're going to have to look at it.
    04-06-2011 07:35 PM
  7. alpinestars1z's Avatar
    Sounds like its stuck in a recovery loop? Never experienced it so I'm not exactly sure. Try using Tiny Umbrella to kick it out of recovery?
    04-06-2011 07:37 PM
  8. poda521's Avatar
    Heading back to the Apple store tomorrow. Had to leave with an appt. because they were backed up till closing.

    If they can't fix it, (which I can't imagine how they can considering I've tried everything) will they swap me out for a refurb or a new one?

    I would have tried TinyUmbrella (which I found through Google) but the Apple store would be closing in 2 hours so I decided to just go ahead and drive rather than gamble on TinyUmbrella.
    04-06-2011 08:26 PM
  9. Massie's Avatar
    But do you have it with you now? You could try TU tonight. Also make sure you have your hosts file set to look to Apple if you're trying to do an official restore. (Google if needed.)

    Also: if you used the iPad baseband to unlock, you can't restore to an official ipsw; you need to use a custom built one or you'll always error out.
    Last edited by Massie; 04-06-2011 at 11:55 PM.
    04-06-2011 11:41 PM
  10. BLiNK's Avatar
    when this happens iTunes should be throwing an error code. most commonly is error 1013

    My Gadget: [HOW-TO] - Fix iTunes Error 1013 When Updating iPhone 4 to iOS 4.3.1
    04-07-2011 01:01 AM
  11. WarrenRSV's Avatar
    Well I stayed up till the early hours of the morning reading and searching solutions and tried most of them with no luck. Then the last thing before I gave up was to try my other laptop, and guess what...................? It worked!! I installed iTunes on my spare laptop and it restored first time. I was then also able to jailbreak because I was trying on 4.3 and didn't realise the latest jailbreak needs 4.3.1.
    04-07-2011 03:11 PM
  12. swampbaby's Avatar
    I was having a similar issue when I was jailbroken on 4.2.1. I would attempt a restore on my MacBook Pro and iTunes would fail to restore the device, yet on a Windows computer it would restore perfectly fine.

    Long story short I had to end up taking my Mac to an Apple store whee they had to erase the hard drive and do a clean install of Snow Leopard. After that iTunes restored perfectly fine.


    Not sure why but I think it may have had something to do with WiFi Sync installed on my computer and jailbroken iPhone.
    04-07-2011 04:15 PM
LINK TO POST COPIED TO CLIPBOARD