1. kevinlovesrice's Avatar
    lately my iphone 4 has been constantly lagging on me...
    anyone got tips?
    I have jailbroken my device , low multitasking , no backgrounder.
    my iPhone lags when I'm typing most of the time.
    and once my iPhone froze on me for about 5 minutes.
    help please
    thanks
    04-06-2011 01:34 AM
  2. korp#IM's Avatar
    Have you tried doing a powercycle? My iPhone isn't jailbroken but if you have a custom theme that could certainly contribute.
    04-08-2011 08:22 PM
  3. OTACORB's Avatar
    I know some are big on the jailbreaking and that is fine, but this is the very reason I don't jailbreak. I've had these experiences with mine and I find just living with it as is give me the best overall user experience. Power to those that wish to jailbreak!
    04-08-2011 08:56 PM
  4. Lylej2k's Avatar
    I've heard of SBSettings slowing the I4 down and causing some lag. I don't use it as I noticed it slowed my iPod down considerably. Perhaps a list of what Jailbroken apps your running would help to find the root of the problem. Another thing, make sure all your JB apps are up to date, running ones that are out of date can cause problems.
    04-08-2011 11:43 PM
  5. icebox93's Avatar
    I have sbsettings and haven't noticed any slowdown in the system. Perhaps it conflicts with something I don't have but it doesnt look like sbsetting is inherently a slow down.
    04-09-2011 02:05 AM
  6. moneymike47's Avatar
    It's probably the jailbreak, try uninstalling recent Cydia apps to see if it fixs itself, and if not, I would restore your iPhone.
    04-09-2011 11:01 AM
  7. Lylej2k's Avatar
    I have sbsettings and haven't noticed any slowdown in the system. Perhaps it conflicts with something I don't have but it doesnt look like sbsetting is inherently a slow down.
    It may have been something I was running with SBSetting on my iPod, not really sure. It was the first iDevice I'd ever jailbroke, and I wen't a little crazy with all the new access and apps I had at my disposal.
    04-09-2011 05:33 PM
  8. Jon Seals's Avatar
    I have a TON of Cydia apps and tweaks... Though if you have Celeste I'd uninstall it, it made my home button stop working for some reason.

    Also, if you have SBSettings, open it and click power and click safe mode and see if it still lags, if it does it has nothing to do with the jailbreak.
    04-09-2011 06:44 PM
  9. Garz's Avatar
    Yes... Restore
    04-09-2011 06:54 PM
  10. yanks19's Avatar
    mine is jailbroken w/sb settings, lockinfo, bite and a few others and no lag but it was taking forever to respring and reboot after updating packages from Cydia.... probably because I restored from a backup of a jailbroken device (i know, bad move). best to just restore as new so that's what I ended up doing.

    if you're worried about losing application data from games and other iTunes store bought apps, get appbackup from Cydia and backup data from those applications and save it to your computer. After you restore and re-jailbreak, replace the backup and restore the data for those apps. great for anything that doesn't sync from or to somewhere other than your device. now that i've tried it i don't think there's any reason to restore from a device backup....ever.
    04-11-2011 01:34 PM
LINK TO POST COPIED TO CLIPBOARD