1. ragavbpl's Avatar
    Hello

    It's my first post and am here with really great hopes

    I am in serious trouble - Recently purchased a new iPhone 4 16gb Factory unlocked which came by default with 4.0.2!
    I jailbreaked it using Limera1n

    Today after the release of unteathered jailbreak I decided to upgrade to 4.3.1 and jailbreak it.

    But the first step itself doesn't work for me i.e. I have downloaded a IPSW(iPhone3_1_4.3.1_8G4_Restore) from apple's server and when I try to restore it to iOS 4.3.1 using iTunes(by pressing shift and restore and browsing to the file) it stucks at "Restoring iphone software" as shown in following image -
    (link to image) i52.tinypic.com/es89ec.jpg

    I have already tried following methods but no luck -

    1) Changing computer!
    2) Re-installing itunes 10.2.1 and also have tried to uninstall apple mobile device support and reinstall it.

    These were the two most prominent methods I found on internet but both didn't work for me.

    Kindly help me asap as it's urgent

    Thank you in advance
    04-04-2011 11:15 AM
  2. Massie's Avatar
    Have you tried just clicking Update in iTunes instead of trying to use Shift/Restore?

    Also, how long are you waiting for it to restore? That image doesn't seem to show any errors.
    04-04-2011 11:30 AM
  3. ragavbpl's Avatar
    It only gives an option to restore as my phone does not contain any firmware because I have to deattach it as it was not moving forward...
    And when I click on restore it gives me an option to Restore and Update!

    And no error comes up.... it just stucks at that point and doesn't show any further progress.
    Last edited by ragavbpl; 04-04-2011 at 02:32 PM.
    04-04-2011 02:27 PM
  4. crystus's Avatar
    You need to get into dfu mode. Since it was removed before the firmware update completed or errored out. Put it in dfu mode and you shouldn't have a problem restoring.
    04-04-2011 02:56 PM
  5. ragavbpl's Avatar
    Already tried that but still does not work.. it just goes uptil a point as mentioned in the screenshot and then it won't further proceed even if I wait for hours....

    Kindly help me some1
    04-04-2011 03:00 PM
  6. Massie's Avatar
    Did you purchase this new or used? It might be worth just visiting an Apple store. But one thing to check is your hosts file...if you've used TinyUmbrella before, be sure to open it and uncheck the "set host file to Cydia" before you update to 4.3.1.
    04-04-2011 03:16 PM
  7. ragavbpl's Avatar
    I purchased it new and I am in a country where iPhone 4 are yet not launched officially and we hardly have number of Apple stores here.. specially not even 1 around my location..

    Also i have removed the host.umbrella file and also removed the last line from my main host file that points the apple.com to cydia's server.

    Also have made a check as follows -

    When I ping apple it shows following:
    Pinging gs.apple.com [17.151.36.30] with 32 bytes of data
    You can see that it's a different IP from what we write in our last line of host file i.e. 74.208.105.171

    so it is resolving to original apple server and not to cydia's server..
    04-04-2011 03:23 PM
  8. ragavbpl's Avatar
    Guys.. thanks all for your support!

    I finally figured it out after doing some work..
    The actual problem was The IPSW file.... it was corrupt! Downloaded a new one again from apple's server and taddaaa.... it worked like charm And took less then 10 minutes for a full restore
    04-04-2011 07:10 PM
LINK TO POST COPIED TO CLIPBOARD