1. dndrich's Avatar
    TiPb Pals:

    Love my Verizon iPhone. Came from the Palm world with wonderful calendaring. I am using Week Cal, which I love, to sync to my main calendar on Google using exchange. Works flawlessly. I have noticed though that my old appointments past November 16 2010 are gone. Is there a 3 month limit on these in Google, or on the phone? I have the phone set to keep all appointments in the past. It is possible I messed this up somehow during the transition to the iPhone, as I was using a pre before that, but I don't think so. So, is this a limitation of Google Calendar? I can't seem to find information on this.
    02-22-2011 02:54 PM
  2. dndrich's Avatar
    Anybody out there?
    02-22-2011 09:34 PM
  3. alpinestars1z's Avatar
    I don't have Week Cal, but from what I'm reading on their website it integrates with the built-in calendar app? So does that mean you still set up exchange through the Mail, Contacts, Calendars settings?

    Because in there, if you scroll down to the bottom section for calendars, it says sync, then gives you the option of events 2 weeks, 1 month, 3 months, 6 months back, and all.

    Could that be what you're looking for?
    02-22-2011 10:50 PM
  4. dndrich's Avatar
    I don't have Week Cal, but from what I'm reading on their website it integrates with the built-in calendar app? So does that mean you still set up exchange through the Mail, Contacts, Calendars settings?

    Because in there, if you scroll down to the bottom section for calendars, it says sync, then gives you the option of events 2 weeks, 1 month, 3 months, 6 months back, and all.

    Could that be what you're looking for?
    I have "all" checked. Week Cal syncs with the native iPhone calendar, so no problem there. Interestingly, I used to sync my Palm Pre using Datebk6 and classic to iCal on my Mac, then through Busysync to Google calendar in the cloud. Now, when I look at iCal, all the old dates are there. But on Google Calendar it is gone past 11/16/2010 for some reason.
    02-22-2011 10:53 PM
  5. dndrich's Avatar
    OOOHHHH. I think I discovered the problem! Looks like one of the options on Busysync that is checked by default is not to publish beyond 3 months! So, I unchecked that, and it is now doing a bunch of syncing! I'll bet that will solve the problem!
    02-22-2011 10:55 PM
  6. alpinestars1z's Avatar
    OOOHHHH. I think I discovered the problem! Looks like one of the options on Busysync that is checked by default is not to publish beyond 3 months! So, I unchecked that, and it is now doing a bunch of syncing! I'll bet that will solve the problem!
    Haha glad you found a solution.
    02-22-2011 10:56 PM
  7. dndrich's Avatar
    Yup. That was it. OK, problem of my own making is now solved!
    02-22-2011 11:07 PM
LINK TO POST COPIED TO CLIPBOARD