1. iphone999's Avatar
    On serveral different WiFi networks I have experienced "Unable to join the netork" errors. It seems to be one of two problems. The first, is that I am getting terrible signal strength. I am less than 20 ft from my router, my laptop shows full reception, my iphone shows 1 bar. I try to connect repeatedly and it gives me the unable to connect error. Have others experienced this bad of reception or is my iPhone defective? Secondly, even if I get really close to the router, and can get 2-3 bars for WiFi, I still frequently get the unable to connect error. Anyone experiencing this? Any idea how to fix it?
    02-18-2011 11:53 PM
  2. BLiNK's Avatar
    i had a similar problem with my other iPhone

    try Settings>General>Reset>Reset Network Settings

    worked for me, hopefully will for you
    02-19-2011 01:31 AM
  3. jtanko78's Avatar
    I am having the same issues as well. going to try the network reset now.

    the reset didnt work, now its telling me "incorrect password" I know its the correct password and i tried 3 times, slower each time to make sure i entered correctly.
    Last edited by jtanko78; 02-19-2011 at 02:46 PM.
    02-19-2011 02:42 PM
  4. rcdanville's Avatar
    i need a password for my i phone 3g win 3897 evey thing i try does not work could you help thank you
    03-07-2012 09:54 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.