1. Icyhot1966's Avatar
    Just tried it in my house in Airplane mode and it wouldn't get a lock in Airplane mode, but neither would my Incredible. I went into settings and network and turned cellular data off (which is probably close to the same thing as Airplane) and got a lock withing 3 seconds. So that is how I will test it tonight.
    03-04-2011 10:20 AM
  2. rihamy2nd's Avatar
    Just tried that. As soon as I put it into airplane mode, it shut the GPS off, too. Looked it up in the iPhone user manual and it verified that it does kill the gps signal. Pffft... Oh, well.
    03-04-2011 10:31 AM
  3. rihamy2nd's Avatar
    Just read your update (I didn't refresh the page before I posted mine). I'll try that, too.
    03-04-2011 10:33 AM
  4. rihamy2nd's Avatar
    OK, not a long enough trip to truly verify it, but it worked on this short 6 minute ride I just made. I've got a job after my current one that will be a good thirty minutes away, so I'll know a little better if that's part of the problem.

    However, after I turned cell data back on and tried to post this update, I got prompted that Safari was not connected to the Internet. Tried restarting safari and refreshing the page - no go. Had to reboot the phone to get network function, again. So, even if this works, (and I'm only willing to accept it as a temporary, short-term solution, at best) it's going to ba a major pain in the butt to go through all of that.
    Icyhot1966 likes this.
    03-04-2011 11:02 AM
  5. Icyhot1966's Avatar
    Probably just need to double tap the home button, "close out" Safari and then reopen it. That may work instead of rebooting the phone. I am JB so I can respring in a matter of seconds so that won't be an issue for me. Hey, maybe this is this issue. It sure would be nice if we could pinpoint it.
    03-04-2011 11:05 AM
  6. rihamy2nd's Avatar
    I'm on the laptop, so I'll go into more detail. I got two separate prompts, one from Safari and another one that popped up just before that one that said something like, "Not subscribed to any 3G networks." Also checked email and it wouldn't connect. Maybe just a one-time glitch because I just gave it another test (20 minute drive home for lunch) and the phone reconnected to the network just fine at the end of this trip.

    As for the GPS, the little globe that indicates GPS signal in MotionX turned red within 15 seconds of initiating this last route, but was only like that for about 5 seconds or less, then it worked flawlessly all the way home. MotionX will verbally announce loss of signal if it loses it for longer than about 30 seconds, I think. On that previous 6 minute trip, the globe turned red just as I was turning into the parking lot of that destination. I failed to mention that because of the distraction over the 3G network not connecting back up. That seems more like "normal" occasional signal loss like I've gotten from time to time with just about any of the past GPS systems I've ever used. It's the 30-60 seconds at a time every 3-4 minutes like this thing has been doing that's unacceptable to me.

    I still have another job with about a 45 minute drive coming up after lunch to test this further and then, of course, the return trip home. Hopefully, you'll get similar results, as well. My fingers are crossed that we'll have some substantial information to tell the "Geniuses." I fully expect them to fix this or they can have their iPhone back and I'll expect Verizon to give me another Android (I traded mine in) without incurring any extra fees.
    03-04-2011 12:38 PM
  7. rihamy2nd's Avatar
    Had to stop off to get parts for the job about 8 or 9 minutes short of my destination. I got a good 35 minutes or more of uninterrupted GPS signal. Instead of leaving MotionX running while I went in the store, I decided to try a couple of things to satisfy my curiosity. Stopped navigation in MotionX and didn't touch the 3G settings (left it off). Went in the store. Came out and turned MotionX back on and selected my previous destination - at this point, I'm testing to see how well the cached map data in MotionX works. Unfortunately, it said it couldn't calculate a route without network connectivity. I turned 3G back on, got the "No active cellular plan" prompt again, but it connected anyway, this time. MotionX routed me. And, with the 3G left on, I lost GPS signal 3 times in the 8 minutes or so that it took to get the rest of the way here.

    I'm still going to give it the "3G off" test all of the way home from here, but it looks pretty conclusive to me. Hopefully it's just a firmware bug. Or, I don't know, if the iPhone 5 rumors are true for a June or July release, then maybe I hope it's a hardware problem. I could wait until then if they'd upgrade us all for free. I know, wishful thinking, right?
    03-04-2011 02:39 PM
  8. Icyhot1966's Avatar
    I tried the Navigon with Cellular data turned off but my speed kept going back and forth from 0 to current speed like it's always done. So I stopped it. On my way home from work tonight I am going to try TomTom. Under normal conditions. And then maybe tomorrow with data turned off. I'm gonna turn this into a week long test session and see if I can determine anything.
    03-04-2011 03:43 PM
  9. rihamy2nd's Avatar
    Mixed things up a little on the way home, based on your speed findings. I forgot that MotionX has a display that shows your speed, so I downloaded a free GPS speedometer app, just to try that with and without data on on my way home. It had a LOT of lag updating my speed, so I didn't really trust it. So, with data turned on, I fired up Waze because it shows speed on the main display and it dawned on me that, even though it's another live updating GPS app, it was the one I was using the other day when I was in the very remote area and noticed that my GPS signal never turned off there. I figured it must cache quite a bit, if not all, of your route. First ten minutes I had it going with data enabled, same old story - GPS is on and off repeatedly. Turned data off while Waze is still going and Waze indicated that it was searching for network, but GPS stayed on constantly for the remainder of my ride home (about 25 minutes). And, Waze had all map data stored, including side street names and the whole lot, all the way to my driveway. As for the speed reading, I never saw it fluctuate a bit from what the van speedo was saying.
    03-04-2011 05:59 PM
  10. Icyhot1966's Avatar
    Well I just got home from work, used TomTom with data on, and it never lost signal. It too shows speed, and it never showed anything different than what my car was. I remember someone saying last week that TomTom had updated their app for the Verizon iPhone. More testing is needed I think...perhaps TomTom IS reliable.
    03-04-2011 07:54 PM
  11. rihamy2nd's Avatar
    I don't know all the specs on the TomTom app. Does it have live traffic or any other type of live data updates (weather, construction, etc)? If so, is that turned on in yours? I'm just wondering if an app that is completely self-contained (or maybe I should say fully cached) and needs no network data versus one that is fully cached, but has to poll the radio occasionally for traffic, etc would behave differently.

    I'm going to try Waze and MotionX again with all of their live update features that can be turned off, disabled. Since MotionX has the ability to preload an entire route and Waze has exhibited that it caches your route, too, I just want to see if I can leave data on while using them. I know there's no guarantee that they won't have something going on in the background that's trying to use data, but if it even cuts back on the frequency and the length of time that the gps gets disabled, it'll be a small victory for me, since I don't rely completely on those traffic updates, anyway. It beats having to turn the cell data on and off all day long.

    Since the built-in Maps app seems to track ok and it needs constant data and your TomTom app worked ok with data on, then maybe there's some truth to the third party apps being at fault. I wouldn't call them buggy like the Apple genius did, but maybe they need to be patched to deal with Verizon's radio. I'd still put money on the OS needing to be updated to give the same functionality to the apps that they had in the AT&T phone, though.
    03-05-2011 09:54 AM
  12. Icyhot1966's Avatar
    I was coming to work today, same route I went home on last night where TomTom worked without hiccup, and within 6 miles I lost GPS 3 times, albeit just a few seconds each time. So I remembered what I had done last night....closed out all apps that were running in the background. So once I did that today, I went the other 8 miles without losing reception. Could that be the issue I wonder. Please try that and let me know the results.

    TomTom has live traffic updates but I haven't paid for that feature yet.
    03-05-2011 04:00 PM
  13. Icyhot1966's Avatar
    On my way home from work tonight, I used TomTom again and again it worked great. Its about 17 miles. I made sure I closed all the other apps out. I am beginning to strongly believe that has something to do with it.
    03-06-2011 01:09 AM
  14. rihamy2nd's Avatar
    I got a notification on the phone yesterday that my network settings would be reconfigured. I let it do its thing. Just made a 75 mile trip using MotionX without a hiccup in GPS signal the entire way.
    03-08-2011 10:56 AM
  15. Icyhot1966's Avatar
    Dude!!! Did you close everything in the background prior to that???
    03-08-2011 11:54 AM
  16. rihamy2nd's Avatar
    No. I haven't tried that, yet. I conducted some tests over the weekend, mostly short hops while my wife and I were driving around, using Zillow, looking at houses and it was back to its old self, in and out. I got to thinking about you turning off all the background apps just about the time we were getting done, so I never did try that, myself. I figured Zillow, being a GPS and network-heavy app was probably causing a lot of probs because I was constantly switching between it and MotionX. Anyway, got that prompt from Verizon late yesterday afternoon and all seems to be well... I hope. I'll let you know if it goes awry, again.
    03-08-2011 12:08 PM
  17. rihamy2nd's Avatar
    Another 50 miles and it's still (mostly) working. The signal indicator showed loss of signal several times, but it was never longr than just a few seconds and very irregular. I've got another long leg of driving, so I'll let you know how it goes.

    BTW, I think I may have invoked that network reconfiguration yesterday. I had gone into the network settings where you turn off the 3G and reset the network settings on the phone. It wasn't long after I did that that I got that prompt from Verizon.
    03-08-2011 03:09 PM
  18. Icyhot1966's Avatar
    I updated mine too, but I haven't had a chance to test the GPS, I have stayed at home all day today LOL
    03-08-2011 03:50 PM
  19. TinLemon's Avatar
    After reading this thread I did a carrier update, tried using the gps after closing all background apps, and also tried using the gps after disabling cellular data. The one solution that worked perfectly was to disable the cellular data. After doing so I never once lost a connection during my normal route to work which typically loses gps signal about a dozen times (10-30 seconds each) during the trip.

    I tested and confirmed that this "fix" worked in Waze and Navigon. I even managed to keep a perfect gps lock this morning during a heavy rain.
    Last edited by TinLemon; 03-09-2011 at 09:23 AM.
    03-09-2011 09:20 AM
  20. Icyhot1966's Avatar
    I can't wait to see if the speed on Navigon drops to 0 when I go to work later.
    03-09-2011 12:16 PM
  21. mi_canuck#IM's Avatar
    i find the GPS on my verizon iphone4 working as well or better than when i had an at&t iphones (3GS & 4)

    locks in quickly and accurately... also, with find my iphone, it pinpoints my location even inside my work office and in my house... (when i look at the satellite view)...

    no complaints on the verizon iphone's GSP at all...
    03-10-2011 10:25 AM
  22. Icyhot1966's Avatar
    True, but the issue seems to be with 3rd party GPS apps. Navigon, TomTom, MotionX, Mapquest Mobile, etc..The actual built in Maps program seems to be the only one who will hold a GPS lock with no loss for an extended period of time without having to try a trick, i.e. closing all apps out or turning cellular data off.
    03-10-2011 10:30 AM
  23. rihamy2nd's Avatar
    Same old routine: abysmal performance. Strange how you'll change a setting and it will work flawlessly for an extended period of time, then the next time you use it, with all settings left the same as before, it goes back to the same repetitive failure mode. I tried killing all background apps. Didn't do anything for me. Turning off the data radio seems to be the only reliable fix.
    03-10-2011 01:41 PM
  24. Icyhot1966's Avatar
    So turning off the data radio gives 100% reliability?? This is crazy...
    03-10-2011 01:53 PM
  25. Icyhot1966's Avatar
    I tell ya...I used the built in Maps coming to work today, used the hybrid map and it was very nice. With it in the compass mode, it is quickly becoming my GPS app of choice. I've also heard the Jailbreak community is working on adding voice turn by turn directions to it. But even without the voice, the phone sits in a holder on my dash so it's easy to read, therefore voice is not a make or break deal. I'll just stick with the built in Maps
    03-10-2011 03:38 PM
125 1234 ...
LINK TO POST COPIED TO CLIPBOARD