1. rstark18's Avatar
    Has anyone had this issue?
    I have gmail setup using exchange on my iPhone 4 and normally it works fine. Starting about a week ago I noticed when I went to check a previous email it told me my password was incorrect and wouldn't let me log in to retrieve mail. I tried everything to get it working but the only thing that worked was deleting the exchange account and recreating it. Now a week later I am gettng the same thing. I can log in to gmail using the web interface but nothing I do will let me in with my exchange account on my phone. The message says "cannot get mail. The username or password is incorrect." One other thing I should add is that I recently configured my gmail account to retrieve a few of my POP accounts from AT&T.
    Anyone else experience this and have a solution?
    01-26-2011 06:48 PM
  2. PinkBanana's Avatar
    Why don't you just use straight forward gmail on your phone? in mail just add a new account and input your gmail username and password. Mine works fine on my 3gs.
    01-27-2011 04:44 AM
  3. anaphora68's Avatar
    They're using exchange because that's how Google sync tells you to set it up.

    I use exchange for my contacts and calendars, and IMAP for Gmail. For some reason, when I setup exchange for Gmail, it wouldn't properly sync my inbox up with the iPhone. It was driving me insane. IMAP is much faster for email, but true "push" isn't working for me at the moment...

    I hope this helps.
    01-27-2011 06:28 AM
  4. Alli's Avatar
    I use only Gmail on Exchange for all my accounts including Google Apps with my personal domain. Everything syncs just fine.
    01-27-2011 06:45 AM
  5. anaphora68's Avatar
    Alli,

    I'll try it later when I'm on WIFI, at home. I don't want to blow through the data required to sync if I can avoid it while I'm at work.
    01-27-2011 07:47 AM
  6. Alli's Avatar
    Syncing your Exchange account requires very little data.
    01-27-2011 07:49 AM
  7. sting7k's Avatar
    They're using exchange because that's how Google sync tells you to set it up.

    I use exchange for my contacts and calendars, and IMAP for Gmail. For some reason, when I setup exchange for Gmail, it wouldn't properly sync my inbox up with the iPhone. It was driving me insane. IMAP is much faster for email, but true "push" isn't working for me at the moment...

    I hope this helps.
    IMAP doesn't push.

    What is happening when you try to use Exchange?
    01-27-2011 03:53 PM
  8. rstark18's Avatar
    First off let me say I resolved it by syncing with itunes. Nothing else short of deleting and remaking my exchange account would fix it. It seems very strange that a sync would fix it though.

    The reason I use exchange is for push email and contacts syncing which imap doesn't do (wish exchange did note syncing, there is always trade-offs).

    FYI @anaphora68 there is a bug when you have both exchange and imap configured for the same account in iOS (at least the way I was using it). The bug is with attachments. If I have exchange configured to do email and imap configured to do other stuff (notes or calendar) then if trying to send an email from an outside app (photos, safari, etc.) that email gets stuck in the outbox and never sends.
    01-27-2011 04:13 PM
  9. anon(153966)'s Avatar
    I say remove the account, and re-add it. Just in case something was not configured correctly initially...
    01-27-2011 04:16 PM
  10. anaphora68's Avatar
    Nevermind, it works.

    To be honest, though, I don't like the implementation of push. I prefer using the IMAP setup for email. Just a preference, though..
    Last edited by anaphora68; 01-27-2011 at 09:15 PM.
    01-27-2011 08:58 PM
  11. Nevosoft's Avatar
    It works for me. Maybe you should retry?
    01-28-2011 04:20 AM
  12. allaboutpunky's Avatar
    I had the same problem last night... kinda.

    I kept receiving a pop up on my phone that said my gmail password was incorrect and to enter my password. After I did that, the error went away but I stopped receiving my push notifications. I would only get email if I physically went into the email button and then the phone would refresh and pull the email.

    I went into my exchange settings and re-entered my password and it appears to be working correctly but I dont want to keep encountering this. Any ideas as to what may be causing this issue?
    02-23-2011 02:07 PM
  13. rstark18's Avatar
    This has popped up a few time for me so I did a clean restore. I haven't had the problem since (lost my angry birds setting though).
    02-23-2011 03:02 PM
  14. markhunsaker's Avatar
    I have my Gmail set up via exchange. My wife has her Gmail through IMAP or whatever the native set up is if you click the Gmail when you're adding an email account.

    I was just checking for fun...her email would receive five seconds after I sent her one...mine was about the same. So it seems to me, Gmail pushes and doesn't need to be set up through exchange.
    02-27-2011 11:47 PM
  15. rstark18's Avatar
    IMAP doesn't sync contacts though
    02-28-2011 02:14 AM
  16. nyc_rock's Avatar
    I have the same exact problem. It doesnt always happen, but it happens often enough to be an issue. I can delete the account and re-add it. Everything seems to work and then I will get the "your password is incorrect". I have gotten this error when setting up gmail as an exchange account and as a regular account through the email settings menu.
    08-02-2011 08:06 AM
LINK TO POST COPIED TO CLIPBOARD