1. mdpatsfan's Avatar
    I have a iphone4 on 4.1. I was jailbroken but I am not right now. I tried to restore and update and my phone will not update to 4.2. Every time I try my phone goes into recovery mode. I was able to restore using the 4.1 ispw file. I even tried using the 4.2 ispw file but that didn't work. Does anyone out their have any ideas why my phone won't update? Thanks for looking.
    01-20-2011 11:30 PM
  2. dpscott's Avatar
    Do you get any error messages?
    01-21-2011 06:12 AM
  3. mdpatsfan's Avatar
    Yes, I'm getting a 1004 and a 1013 code.
    01-21-2011 09:17 AM
  4. dpscott's Avatar
    01-21-2011 03:55 PM
  5. Ipheuria's Avatar
    I would try from looking at that upgrading your iTunes, upgrading on a different computer. You can try putting it into DFU mode, this is different from Recovery mode search for the procedure. The DFU mode allows the phone to reload the firmware without loading the firmware that is already on the phone. I would also suggest searching the internet for the errors. I had a 3Gs that just wouldn't load the firmware and it ended up being a chip problem the phone had to be replaced.
    01-21-2011 08:03 PM
  6. alexander__ekin's Avatar
    More complete solution for those not knowing where to find the file:

    On Mac:
    * Open Finder
    * Hold down COMMAND + SHIFT keys and press 'G'
    * Enter "/private/etc/" in the field and press "Go"
    * Find "hosts" file in the directory
    * Drag the file to your desktop
    * Open it in text editor
    * Remove the line that has gs.apple.com entirely or put a # at the beginning of it to comment it out
    * Save the file
    * Drag it back to the /private/etc/ folder.
    * You'd need to enter your username and password to authenticate the move

    On Windows:

    * Locate the hosts file in one of the following directories:
    Windows 95/98/Me c:\windows\hosts
    Windows NT/2000/XP Pro c:\winnt\system32\drivers\etc\hosts
    Windows XP, Vista, 7 c:\windows\system32\drivers\etc\hosts
    * Right click and click on "Open With..." and then click on "Notepad" on the list.
    * Remove the line that has gs.apple.com completely and save the file.

    This should work fine.
    01-21-2011 11:14 PM
  7. mdpatsfan's Avatar
    Sorry Im just back to you all, life gets in the way some times. I was able to get 4.2 on my phone via a friends computer. Thanks for all of your ides. I did change the file alexander_ekin wrote about. That way my mac will be ready if I need to restore or or when 4.3 comes out. Many Thanks!!
    01-23-2011 03:03 PM
LINK TO POST COPIED TO CLIPBOARD