1. ItnStln's Avatar
    I've noticed that my contacts aren't syncing with my Google Sync account. My calender events are, however. And in the exchange settings, it's set to allow syncing my contacts. Is anyone else having a problem with this? If so, did you get it fixed?
    01-05-2011 04:37 PM
  2. applejosh's Avatar
    I am not currently syncing contacts with any Google contacts, but I seem to recall that only contacts designated as "My Contacts" were synced. Are your contacts in that "group"? Also, have you tried removing the account and re-adding? (I believe this will clear out any data on the phone tied to the account, but since it should be synced with Google, it should all come back when the account is added again.)

    (I assume you looked at all Contacts groups in the contacts tab of the phone app as well.)
    01-05-2011 06:40 PM
  3. rstark18's Avatar
    Do you see Google Exchange in the Groups tab?
    01-05-2011 07:06 PM
  4. ItnStln's Avatar
    Do you see Google Exchange in the Groups tab?
    YesIn my groups, there's "All Contacts," "All on My iPhone," and under my GMail e-mail, there's a tab labeled "Contacts."

    The problem that I'm having is that the new contacts that I add on my iPhone don't show up on my gmail.com address book...I'm not having this problem with my iPod Touch, however.
    01-05-2011 08:35 PM
  5. rstark18's Avatar
    By any chance do you have two setups for the same account (one exchange, one imap) for any reason? I did this and it screwed some things up.

    You are using an exchange account correct?

    Also, did you delete the account on your phone and re-add it?
    01-05-2011 09:08 PM
  6. ItnStln's Avatar
    By any chance do you have two setups for the same account (one exchange, one imap) for any reason? I did this and it screwed some things up.

    You are using an exchange account correct?

    Also, did you delete the account on your phone and re-add it?
    I set it up using Exchange...the directions that I used are here:
    Set Up Your Apple Device for Google Sync : Google Sync - Google Mobile Help

    And yes, I deleted it and am still having the same problem...I'll delete it again here in a little bit and hope that works.
    01-05-2011 09:25 PM
  7. ItnStln's Avatar
    Just deleted the google exchange account, restarted my iPhone, and re-added the account...same problem.
    01-05-2011 09:32 PM
  8. rstark18's Avatar
    If you add a contact in Google (on a computer) does it add to the iPhone?

    Do you have other mail accounts on the iPhone (just trying to think of something that might be affecting exchange)?
    01-06-2011 12:42 AM
  9. ItnStln's Avatar
    If you add a contact in Google (on a computer) does it add to the iPhone?

    Do you have other mail accounts on the iPhone (just trying to think of something that might be affecting exchange)?
    Yes, when I add a contact on Google, it adds it to the phone...When I add a contact on my phone, it does NOT add it to Google.

    The only other mail account that I have on my iPhone is my AOL account.

    Thanks for your help, rstark18!
    01-07-2011 02:42 PM
  10. Laelipoo's Avatar
    It might not be saving the contacts you're adding to GMail. Instead, it may be saving them on the phone itself. Check the 'On My iPhone' group to see if the people you've already added are there.
    01-07-2011 04:45 PM
  11. rstark18's Avatar
    Good point @laelipoo. Check to see what your default Contacts account is (Settings>Mail, Contacts, Calendar>Contacts>Default Account).
    ItnStln likes this.
    01-07-2011 05:35 PM
  12. ItnStln's Avatar
    It might not be saving the contacts you're adding to GMail. Instead, it may be saving them on the phone itself. Check the 'On My iPhone' group to see if the people you've already added are there.
    Sure enough that's what's happening. Is there a way to fix this?
    01-08-2011 03:45 PM
  13. Laelipoo's Avatar
    Sure enough that's what's happening. Is there a way to fix this?
    What I would do is change the default account, as @rstark18 has detailed, then re-add the contacts. Once you can see them in GMail, I would delete them from the phone itself.
    ItnStln likes this.
    01-08-2011 05:14 PM
  14. ItnStln's Avatar
    What I would do is change the default account, as @rstark18 has detailed, then re-add the contacts. Once you can see them in GMail, I would delete them from the phone itself.
    So are you saying to make my GMail account the default?
    01-08-2011 06:58 PM
  15. rstark18's Avatar
    Yes, in order to sync to gmail it has to be default.
    01-08-2011 08:34 PM
  16. buzzdar#WN's Avatar
    Does this work on the iPod touch 4 as well to get them to sync.


    Sent from my iPod touch using Tapatalk on the VZW Network.
    01-08-2011 09:41 PM
  17. rstark18's Avatar
    I assume so since it is running iOS.
    01-09-2011 02:24 PM
  18. Kannon#AC's Avatar
    A little off topic, but I sync my contacts to Windows Live since the contact pictures aren't ruined like they are with google sync.
    01-09-2011 02:30 PM
  19. ItnStln's Avatar
    Yes, in order to sync to gmail it has to be default.
    Sure enough, my GMail account wasn't set as the default contacts account...changed that and it worked. Thanks for your help, rstark18!
    01-11-2011 06:46 PM
  20. ItnStln's Avatar
    A little off topic, but I sync my contacts to Windows Live since the contact pictures aren't ruined like they are with google sync.
    How do you sync the contacts through Windows Live? I didn't know that you could.
    01-11-2011 06:47 PM
LINK TO POST COPIED TO CLIPBOARD