1. Xilus333's Avatar
    My iPhone 4 is in the DFU mode(the screen is black), and I cannot make it work!

    I wanted to upgrade from 4.0.2 to 4.1 without baseband update with TinyUmbrella, but had a 1604 error. Then I read about iReb, that can deal with this error. So, I put iPhone in DFU, pwn it with iReb and upgrade to 4.1 with TinyUmbrella. In the end, I got a 1004 error, which meant I succesfully upgrade, but me phone is still in DFU! I tried iReb, I tried sn0wbreaze, I tried RecBoot, I tried just hold the Home and Power button - but nothing is working Can I somehow solve the problem without restoring to 4.2.1?
    12-25-2010 07:59 AM
  2. dpscott's Avatar
    Tried using TinyUmbrella to boot it out?

    "Kick Device Out of Recovery button on TinyUmbrella right below the Start TSS Server button. Thats it!
    12-25-2010 12:03 PM
  3. Cleveland's Avatar
    ^^^^ exactly what was said above, use tinyumbrella to kick it out of DFU mode
    12-25-2010 12:39 PM
  4. pizzafootbal's Avatar
    I've had problems with this too, try using another computer
    12-25-2010 12:47 PM
  5. Xilus333's Avatar
    Of course I tried it! But TinyUmbrella don't see the phone in DFU, only in usual recovery mode. And I found out, that I can boot it: but only through redsn0w "just boot tethered" option. Can I somehow made it work normal, I have a 4.1, not a 4.2.1 firmware after all!
    12-26-2010 02:39 AM
  6. Cleveland's Avatar
    did you save your blobs for 4.1 ??
    12-26-2010 02:49 AM
  7. Xilus333's Avatar
    did you save your blobs for 4.1 ??
    No, I've bought it recently.
    12-26-2010 03:04 AM
  8. Cleveland's Avatar
    Well here are two issues I see now that I reread your OP, first apple does not accept any more requests for 4.1, and you can't save your blobs for 4.1 now anyways because of that ... So ultimately the problem is you'll have to install 4.2.1 BUT tinyumbrella will still keep the old baseband but you'll have to wait to jailbreak
    12-26-2010 10:36 AM
LINK TO POST COPIED TO CLIPBOARD