1. Jellotime91's Avatar
    So I'm using my iPhone 4 in bed as usual and it keeps dropping off of wifi. I have great wifi reception as Im literally like 4 feet away from the router, and yet it continually drops off of my wifi connection. Never happened before but now it keeps happening over and over again..

    Anyone else experienced this?
    11-06-2010 02:09 AM
  2. Tramain's Avatar
    Mine does the same, I'm taking it back to the Apple Store at 1PM because there are other things wrong with it such as proximity issue.
    11-06-2010 07:04 AM
  3. Massie's Avatar
    Did you try Reset Network Settings?
    11-06-2010 08:25 AM
  4. MustangLife's Avatar
    I had the same problem with my 3GS in 2009. I think I turned airplane mode off and on and than reset network settings. Airplane mode was 1 of those things just seems to help our phones with a few issues turning it off and on.

    Josh
    11-06-2010 01:04 PM
  5. iquinn's Avatar
    I have had issues like this in the past as well. When I bought the router that I have now I had a very hard time getting my 3GS to stay on wi-fi for the first day or so. I kept telling it to forget the network and then would set it up from scratch and that seemed to fix the issue after a while.
    11-06-2010 01:09 PM
  6. Jellotime91's Avatar
    Reset network settings, didn't work.
    Restored now, still didn't work.

    Sigh. :/
    11-06-2010 03:54 PM
  7. iLurk13's Avatar
    Try rebooting your phone.
    11-06-2010 07:55 PM
  8. Toymaker's Avatar
    Rebooting won't work. I have even restored as a new profile 3 times.
    11-07-2010 03:27 PM
  9. sting7k's Avatar
    Reset your router.
    11-07-2010 03:47 PM
  10. Jellotime91's Avatar
    Reset your router.
    Also reset my router recently.

    I turned off cellular data and that seemed to do the trick. although it will be annoying when I go back to work on Monday. -_-
    11-07-2010 03:52 PM
  11. big9erfan's Avatar
    I have the same problem, drops off wifi a lot.
    11-07-2010 04:12 PM
  12. Jellotime91's Avatar
    I have the same problem, drops off wifi a lot.
    It's weird cause it just started happening recently.. Or maybe it's been happening and I didn't notice. That would explain the huge uptick in my data use since I got the iPhone 4... Damn it. I think I wanna ask Apple for some money now. lol
    11-07-2010 06:25 PM
  13. Toymaker's Avatar
    Tell me about it, Both my wife and I have the $15 200MB plan and it happens all the time. I hope it gets fixed in the 4.2 update along with the bluetooth.
    11-07-2010 06:51 PM
  14. sting7k's Avatar
    Pretty strange, I haven't noticed it happening to mine. When you say it drops, does the wifi symbol just go away and 3G pops up while you are using it?
    11-07-2010 07:12 PM
  15. Toymaker's Avatar
    Yeah, sometimes it just switches connections. Other times when I'm in an app that uses data like email or safari it Sometimes sees my network and asks me if I want to connect. When I select it, sometimes I get on and other times it asks me for the passkey. The crazy thing is the password Never works unless I leave the app and enter it in the settings app.

    Wifi is as unreliable as my bluetooth connection which drops randomly but only when I know I am near a wifi signal whether it's a known network or not. I think the iPhone 4 has a serious radio problem.

    All in all my iPhone experience is a bit marred by these issues as well as random massive 3G data charges when I hardly use it.

    Apple really botched this one. I hope they fix it soon.
    11-08-2010 02:12 AM
  16. Jellotime91's Avatar
    @toymaker
    Yours sounds a little more serious. May have something to do with your router setup, if not it's likely a hardware issue.

    I am at a loss for why the iPhone 4 gobbles more data though. I have 1GB and I never went over on my 3GS or 3G (which I used WAY more during the day at school than I do now at work), but now I go over on data every month.

    Sometimes the wifi icon doesn't go away but it is still actually using 3G to connect! Other times I'm connected to wifi but the wifi icon isn't there and it keeps using 3G. Annoying as hell...
    11-08-2010 07:01 AM
  17. Toymaker's Avatar
    Jellotime,
    Check out the Apple support forums under the section- Wifi, 3G, Bluetooth topic- "Unknown data usage early in the morning" and some of the other "Wifi disconnecting from my Router", and Bluetooth topics.
    It's all there.
    11-08-2010 08:52 AM
  18. Chavista's Avatar
    Dude, this seriously sounds like a router issue. I would try changing my router wireless channel You might be getting some serious interference.
    11-08-2010 04:34 PM
LINK TO POST COPIED TO CLIPBOARD