1. talkram's Avatar
    Hey all, I got an iPhone from a friend that would not turn on, so after charging it for a couple days I went to load it into itunes, itunes tells me that it is in dfu mode which means that the only option is to restore. When I try to restore it it loads everything up fine until it gets to 75% where it restores the iphone firmware. Once it gets to this spot it just stays there for hours until I unplug it and start the whole process over again. I have no idea what the previous OS version was so I can not use redsnow to load a new OS on. Any thoughts or suggestions on how to repair this, or is it junk now.

    iphone 3g

    the screen works when it is plugged in

    can not power up when unplugged

    can not finish the restore process
    10-24-2010 10:31 PM
  2. Slyfi's Avatar
    sounds like there is an internal issue that might keep it from powering up, recommend taking it to an Apple store and see if they can help you
    10-24-2010 10:43 PM
  3. Mrkovach's Avatar
    I agree with Slyfi. It sounds like a hardware problem. You could try using Tiny Umbrella to kick the phone out of DFU mode. It may operate again. You could try a restore with the Tiny Umbrella Server running to see if that method works. It will error out restoring the firmware, this is when you kick it out of DFU mode.
    Good luck.
    Mike
    10-24-2010 11:00 PM
  4. talkram's Avatar
    Yeah the problem is that it does not error out. It just stays in "Restoring iphone firmware" mode for days.

    I tried using tiny umbrella but so far it has done nothing but make me look cool, lol
    10-25-2010 12:32 AM
  5. talkram's Avatar
    update I just looked inside this thing and it does have water damage. No corrosion (I repaired cell phones for a couple years) so that is good, however the indicators are red, same with the one in the headphone jack. I have used a multimeter and I have current through all the circuits I can see. . . It restores the software, just gets stuck on the damn firmware...grrr
    10-25-2010 12:35 AM
  6. Slyfi's Avatar
    try restoring it on a different computer i find it impossible to restore on my desktop but works just fine on my laptop
    10-25-2010 12:42 AM
  7. Tugs4Life's Avatar
    have you blocked any services on your desktop? (downgrading purposes) sometimes this can effect an update, as it did for my iphone 3GS going to 4.0.1
    10-25-2010 02:51 AM
  8. talkram's Avatar
    I don't know. I can usually figure these types of problems out, but everything I have tried has yet to work. I am going to uninstall itunes completely and try for a fresh install and see if that works.
    10-25-2010 02:35 PM
  9. Boots's Avatar
    Was it jailbroken? Are you redirecting to Saurik's server? If so disable that, mine got stuck when restoring to 4.1 when I had it pointed to his server.
    10-25-2010 06:59 PM
  10. talkram's Avatar
    Never jailbroken to my knowledge, and I am trying to reload it using plain old itunes, however at this point I am willing to try anything to get it beyond the 75%
    10-25-2010 07:04 PM
  11. Boots's Avatar
    Try it on a different computer and use a different USB cable, you never know.
    10-25-2010 07:07 PM
  12. Llmnky's Avatar
    Yea I would just take it to Apple and see what they would be able to do for you. Worst that could happen is you'll still have a broken phone. Sometimes Apple will give you a discount on a new one. One of my buds went swimming with his iPhone 4 and thats what he told the genus bar and they just gave him a brand new one but he was still under warranty(and warranty does not cover water damage). It looks like you have tried all the options so i would just take it to apple and see what options they will give you. Or if nothing works you can sell it on eBay as a water damaged as is. : )
    10-26-2010 12:04 AM
LINK TO POST COPIED TO CLIPBOARD