1. jburke2510JBURJburke2510's Avatar
    Yesterday, the app store on my phone started acting up. I noticed when I clicked kn "updates", the page would not load. Just now, I tried downloading an app, after I clicked on the button to install it, my homescreen just showed a blank icon with "waiting" underneath. A few minutes later, the box prompting me to enter my password popped up, and now it's still stuck on "waiting". My updates page still will not load. Can anyone offer any ideas?? Thanks.
    10-17-2010 01:09 AM
  2. Slyfi's Avatar
    ok do this in order and check to see if it fixes the problem after each:

    make sure your in an area with good signal or make sure your wifi doesn't have any restrictions set up by an admin,

    if the above are checked then,
    go to home screen, double click the home button, hold down the app store icon that appears in the menu, when it goes to jiggly mode tap the red button,

    if that didn't work try this,
    restart phone,

    if that didn't work try this,
    go to featured tab in the app store app and log out of your account then back in,

    and if none of those worked,
    back up and restore on your computer,

    hope this helped and best of luck
    10-17-2010 01:28 AM