1. seyheykid's Avatar
    I have a new iphone 4 which is my first i phone. I cannot connect to my NETGEAR DGN2000 router for wi fi. The phone recognizes the router and I am entering the encryption code but nothing. I have the security setting at WPA2. I have been able to access other wi fi sites. Anyone connected to a NETGEAR router? I set up the router and have been able to get several laptops to access. I even tried to manually enter the iphone with the MAC on the phone but the router is not recognizing the phone.
    10-14-2010 11:25 PM
  2. Massie's Avatar
    Had a similar problem once that was something to do with IP protocols (ip4 vs ip6 I think). Wish I had more info for you, but maybe that will help.
    10-14-2010 11:34 PM
  3. seyheykid's Avatar
    Thanks, I am considering all options.
    10-15-2010 12:57 AM
  4. Massie's Avatar
    For what it's worth, the only time I've ever had this trouble is with Netgear routers. If you have access to a different brand, it's worth trying it out.
    10-15-2010 01:42 AM
  5. Wallace's Avatar
    Does your router have MAC filtering enabled by any chance? If so, you will have to configure router to accept the MAC address of your iPhone.
    seyheykid likes this.
    10-15-2010 07:25 AM
  6. sting7k's Avatar
    It's WPA2, I've never gotten an iPhone to connect to a WPA2 network on any router.
    10-15-2010 11:06 AM
  7. seyheykid's Avatar
    Its doesn't work on any security setting. I have even tried it with security disabled (not that I would keep it that way). I'll check on the MAC filtering. I tried to enter the MAC address of the phone but it wouldn't accept it as a valid address. I appreciate all of the help.
    10-15-2010 03:40 PM
  8. liquidzoo's Avatar
    I have a Netgear router (WNR2000) that has WPA2 and MAC filtering enabled. Both my iPhone and my wife's saw the router immediately after I entered the MAC addresses into the filter, and they connected right away once I entered the password.

    Not a lot of help to your situation, I know, but just relaying my story. Had to make sure that I had the correct password, but after that it worked with no issues.
    seyheykid likes this.
    10-15-2010 04:40 PM
  9. john.woody's Avatar
    Doesthe phone see the router?, If no is the ssid hidden or not? Another thing to try is the channel, if you're up at the top 11-13 try changing it to 3 or 4.
    10-16-2010 04:26 AM
  10. seyheykid's Avatar
    SUCCESS! I disabled the MAC filtering which allowed the phone to access the router. Once recognized, I checked (enabled) the wireless device as trusted and was then able to go back and turn on MAC filtering again. At first it wouldn't work on WPA2, only WPA, but several hours later it was OK on WPA2. I had tried entering the MAC manually earlier but it wouldn't accept the address. If the MAC filtering had been turned off earlier, I believe it would have. Thanks to all of you for your help, especially Wallace. I believe the "MAC filtering " situation was really the root of the issue.
    10-16-2010 11:53 AM
  11. Wallace's Avatar
    Just glad to have helped!
    10-16-2010 12:09 PM
  12. Reparkable's Avatar
    Make sure your router has the latest firmware too. I hadn't had the latest firmware and couldn't connect to my router, until I updated.
    10-16-2010 01:05 PM
LINK TO POST COPIED TO CLIPBOARD