1. slalomskie's Avatar
    When trying to upgrade from 4.02 to 4.1 I get the error The iPhone "iPhone" could not be restored. An unknown error occured (2003)

    Any one have this trouble?

    When I disconnect and re connect I get the message that iTunes has deteced an Iphone in recovery mode. You must restore this iPhone before it can be used with iTunes.

    I try this and get the same error as listed above.

    On my iPhone screen is the iTunes logo with the Cable indicating it needs me to plug into iTunes.
    09-08-2010 03:38 PM
  2. morgantm89's Avatar
    Try using a different computer.
    09-08-2010 04:27 PM
  3. Tkf's Avatar
    Try DFU mode.
    09-08-2010 04:30 PM
  4. slalomskie's Avatar
    Try using a different computer.
    I ended up plugging into my wifes computer and getting the phone up and running that way then restored from backup on mine.

    Thanks.
    09-08-2010 08:31 PM
  5. 3seven1's Avatar
    I had the same issue. Lucky for me I just got the iphone 4 and didn't have any of my info on it yet. The error code I got was 1004. It wouldn't restore on my phone anymore and I had to drive to my moms house to use her computer. That worked and i'm up and running again but that was annoying. I wonder who else had this problem of not being able to restore.
    09-08-2010 08:36 PM
  6. Cup_Cakr's Avatar
    Urgh. Have had this issue with my husbands iPhone. We do all updates on my laptop now. His iTunes does this every time to his phone.

    Maybe if he downloads iTunes 10 it may fix the problem...
    09-08-2010 09:00 PM
  7. msm0511's Avatar
    Urgh. Have had this issue with my husbands iPhone. We do all updates on my laptop now. His iTunes does this every time to his phone.

    Maybe if he downloads iTunes 10 it may fix the problem...
    I believe you have to have iTunes 10 for the update.
    09-08-2010 09:11 PM
  8. SaberSerene's Avatar
    I had the same issue. Lucky for me I just got the iphone 4 and didn't have any of my info on it yet. The error code I got was 1004. It wouldn't restore on my phone anymore and I had to drive to my moms house to use her computer. That worked and i'm up and running again but that was annoying. I wonder who else had this problem of not being able to restore.
    My iTunes has been updated to 10 since its launch. I had this problem before with my iPhone 4 failing at restoring. My error message was 1611 and I researched my problem on several sites. I found a good one. sinfuliphone.com I think it was that. anyways. I read to use a different usb port and to unplug iPhone then reboot computer then plug it in the other usb port. This worked. I think so because one of my usb ports has more power or the their is another problem with iTunes or the iPhone 4 itself.
    09-08-2010 09:49 PM
  9. NHL Fever's Avatar
    This has been happening to people who have previously jailbroken a phone on the computer they are using, or who have run Tiny Umbrella for example. If you have used Tiny Umbrella in the past to back up your SHSH blobs, when it errors you and then pushes you back to the restore screen, just hit "kick me out of restore mode" button in TU and you will be good to go.
    09-09-2010 11:46 AM
  10. iNitvizn's Avatar
    Urgh. Have had this issue with my husbands iPhone. We do all updates on my laptop now. His iTunes does this every time to his phone.

    Maybe if he downloads iTunes 10 it may fix the problem...
    Not likely. I have this issue on my laptop and it always fails to update even on version 10. I have to use my wife's laptop to update then restore from backup on mine...frustrating but I haven't found a fix yet
    09-09-2010 11:56 AM
  11. slalomskie's Avatar
    I have been having trouble updating / syncing my phone for some time. I usuaully have to go and delete my voice recordings to sync.
    09-09-2010 12:24 PM
  12. Cup_Cakr's Avatar
    I believe you have to have iTunes 10 for the update.
    Yeah, but we have been updating his iPhone on my laptop. I'm sure he will get around to downloading it.
    09-10-2010 04:47 AM
  13. kendo's Avatar
    Luckily, my update to 4.1 went very smoothly. No problems at all. I do have iTunes 10 loaded on my Mac Mini, and everything worked as advertised.
    09-10-2010 05:05 AM
LINK TO POST COPIED TO CLIPBOARD