1. marwanshkifi's Avatar
    i bought an iPhone 4 , from the first batch on iphones sent out..officially unlocked. im currently situated in Lebanon, and every time i put my simcard in, the reception dies after 15 minutes and i would have to restart the phone to get reception.


    is there anything i need to do? or if anyone can help me out? i payed alot of money to get ahold of this phone and now i cant use it!

    please any help would be appreciated.
    08-28-2010 08:30 AM
  2. Jeremy's Avatar
    So you are saying you go into "no service" and it never returns until you restart the phone?
    08-28-2010 09:07 AM
  3. marwanshkifi's Avatar
    thats correct..
    08-28-2010 10:05 AM
  4. Rene Ritchie's Avatar
    MicroSIM or did you cut down a MiniSIM to fit? Did you ask your carrier about the problem?
    08-28-2010 10:07 AM
  5. Jeremy's Avatar
    It sounds really odd that you'd get service for a period of time then lose it for it never to come back. I'd go back to where you got the device and ask it to be replaced. It may be a SIM issue like Rene mentioned but I don't think it would work at all just to cut out at a later time period.
    08-28-2010 10:10 AM
  6. marwanshkifi's Avatar
    i cut down my sim card, my friends have the phone and its workin fine, i dnt understand why mine is doing this?! is there a possibility that i cut the sim wrong?
    08-28-2010 10:49 AM
  7. toomanyphones's Avatar
    The cut down sim is a possible problem. I find when I tried one it was flakey but not loss of service on regular interval. Note that our three Canadian carriers pushed carrier settings to the iPhone on release. So it could also be a carrier problem.
    08-28-2010 12:02 PM
LINK TO POST COPIED TO CLIPBOARD