1. giancarlo's Avatar
    So I am taking the liberty of troubling you guys with this problem of mine.

    I bought this iPhone 4 on Aug 8'th from S'pore.Its a Singtel handset and is Unlocked(Ps: Locking a handset is illegal in S'pore).I am in India and on Airtel.

    I first cut my Sim to Micro Sim size perfectly(Using sim cutter),then I connected it to iTunes(Latest Version), then the activation process went on but displayed an error which i dismissed in the spur of the moment but the whole process went on i got a "Waiting for activation" message, though iTunes carried on with syncing data and finished fine.And of course "No Service" at the top.

    2 Hours into the process I was still waiting at the "Waiting for activation" pop up.I started getting restless so I began using my "precious".Beautiful device I must say(Wont say phone as I still cant make calls with it:-), Funnily, WIFI was working perfectly(all other features were working fine actually except the network ones) Then I ended up opening Jailbreakme.com and successfully jailbroke the handset and followed it by unlocking it with Ultrasn0w 1.1-1.

    All this before I completed activation.Then after about 5 hours(Post syncing with iTunes for the first time) I got the "Your iPhone is activated" message.But guess what?, still "No Service" at the top left of the screen(And I cannot make calls,texts,data etc so its not the makeitmine issue").

    I tried switching off the handset,"Reset all settings","Reset Network Settings","Airplane mode On/Off" restoring handset to 4.0.1(holding shift and selecting downloaded 4.0.1 firmware as apple was providing restore only to 4.0.2).

    Jailbroke and Unlocked again,Between all of this I also managed to save my blobs in Cydia(Just so that I can restore back to 4.0.1 from 4.0.2 if I upgraded).But No..My phone simply shows "No Service".

    It reads my number fine(Airtel India), It shows my carrier name and one signal bar every time it activates(For about 2-3 seconds) and goes into Searching..and then "No Service".

    It has been 3 frustrating days now, and as a final try, I upgraded my phone to 4.0.2(Something is better than Nothing) but same issue."No Service"

    Now comes the most cliched line of every apple user "Can somebody please help Me ?"
    Last edited by giancarlo; 08-17-2010 at 07:36 AM.
    08-15-2010 03:53 AM
  2. Massie's Avatar
    Can you try a new SIM? How about restoring as a new phone?
    08-15-2010 11:22 AM
  3. Alli's Avatar
    I would definitely restore as new. If your phone is unlocked, don't bother going through the unlock process from Cydia. Make sure your phone is working before jailbreaking so you know the phone is working.
    08-15-2010 11:47 AM
  4. ghostface147's Avatar
    That's what I was thinking....why unlock it via JB when it's already unlocked.
    08-15-2010 11:55 AM
  5. LCW's Avatar
    wait - OP are you on 4.0.2? or was the device ever updated to 4.0.2?

    could be a problem... downgrading to 4.0.1 is not as simple as just holding shift (or option on mac) and hitting 'restore'.... you have to alter the hosts file, and have it point to the cydia ip address, or your local machine (if blobs also saved locally)... downgrading is NOT a simple process and can get messed up rather easily... just a thought, i'm thinking that is what your problem is (if you have either upgraded to 4.0.2 that is)...
    08-15-2010 12:11 PM
  6. giancarlo's Avatar
    @Massie

    Yes, this is my second SIM.The first SIM I cut by hand down to micro-Sim size, So when this "No Service" issue appeared, I suspected my Sim so I got a replacement SIM,got it activated and got it cut with a Sim cutter this time.Also, both these SIMs work perfectly with an adapter on my Galaxy S.(The first SIM is of course de-activated now)

    Yes, I have restored the phone to 4.0.1 twice and 4.0.2(Current) as a new iPhone.

    @LCW

    Yes, I am aware of adding a command line in the hosts file to downgrade to 4.0.1 from 4.0.2 before choosing "Restore".But I have not made an attempt to restore to 4.0.1, because I have already managed restored to 4.0.1 as a new phone and it did not solve my problem.So, I just felt that staying on 4.0.2 would give me the best chance to troubleshoot this issue.

    I am simply too tired after reading through countless posts on different forums for the last 60 hours between restoring, jailbreaking,unlocking,updating and rebooting the iPhone through repeated cycles.You can take this as the biggest compliment to the iPhone 4 as if it was any other device putting up these tantrums I would have simply chucked it outta the window.
    08-15-2010 12:48 PM
  7. stkywik's Avatar
    Stupid question time: does the carrier's signal actaully cover the area you're in?
    08-16-2010 10:37 AM
  8. nies's Avatar
    thats rough man
    08-16-2010 04:07 PM
  9. giancarlo's Avatar
    @STKYWIK

    Yes, my carrier does cover the area I live in..as I have been using the carrier "Airtel" for quite some time now.

    :: Update ::

    After 96 hours of experimentation and retrospection; I have managed to nail the problem!

    It is the the SIM CARD.Though I tried three different sims of the same carrier cut down to micro size with a cutter, this is the first time I inserted a micro sim of another carrier And Voil!

    However the reception appears to be very choppy going upto a maximum of 3 bars only and staying at 1 bar 70% of the time and "No service" 10% of the time.

    I will have to deduce that this a Hardware Issue and I'm returning the phone back to Apple in the next couple of days for a replacement.By far my worst Apple product experience.

    Note: Some carrier's micro Sim do not work on the iPhone (No Sevice) even though they are cut perfectly using a cutter.This can be put down to Sim architecture/design...especially on the Left half, the one that in some cases gets masked under the Sim tray.
    Last edited by giancarlo; 08-17-2010 at 07:36 AM.
    08-17-2010 02:04 AM
LINK TO POST COPIED TO CLIPBOARD