1. c5vettes's Avatar
    Yesterday, for the first time since I got my iPhone 4 on launch day, I removed the micro SIM from it to show a friend how small it was. I immediately put it back in after about a minute and when I did, I got a popup saying "SIM Failure" followed by "No SIM card inserted." I took it back out and put it back in and after about 20 seconds, I got service again without errors. I initially thought it was a fluke. Not 5 minutes later I glance over at the phone which is sitting on my desk and sure enough, there's that popup again saying "No SIM card inserted." I toggled Airplane mode on and off and was then greeted with "SIM Failure" and "Invalid SIM." I took the SIM out and put it back in and everything appeared to work again. I had no more issues for about 6 hours until late last night when once again I noticed the "No SIM card inserted" message popup again for no reason as the phone was lying my nightstand. Toggling Airplane mode did not get rid of the message this time nor did resetting the network settings nor did a reboot. I had to take the card out and put it back in at which time I got service back. This morning when I woke up, everything was fine. On my drive to work however, the "SIM Failure" and "Invalid SIM" messages kept popping up out of the blue and wouldn't go away. When I got to work I took out the SIM and put it back in and for about 4 hours, I had no further problems. All of a sudden I starting getting those popups again and decided to head to the AT&T store to get a replacement SIM. I went and they gladly replaced the SIM with a new one for no charge. It worked immediately. 5 minutes after leaving the store however, boom, "SIM Failure," etc popups began again.

    Anyone else experience anything like this? It's a 32GB iPhone 4 with iOS 4.0.1 installed. I jailbroke it via JailbreakMe a couple days after it was available. I've had no problems whatsoever with it until I popped out that SIM to show my friend yesterday. It makes no sense and I fear having to go through the hassle of having the phone replaced.

    Any input is appreciated!
    08-13-2010 01:59 PM
  2. touchyphone's Avatar
    Sounds like you need to re-seat the sim, make sure its holstered in the slot properly.
    08-13-2010 03:02 PM
  3. noaim's Avatar
    I would try as touchyphone said but this makes me not want to pull my sim out for anything
    08-13-2010 03:40 PM
  4. traviesito77's Avatar
    I have the exact same issue so please advise what could be a possible solution
    08-24-2010 05:54 PM
  5. ferraristef's Avatar
    Some SIM cards if they are pulled out of the phone while it is on it could damage the card. Im in canada and my friend did this and it said the same thing. the card was fried then he went and got a new one and it worked again, but if you went to the ATT store and got a new one and it still does the same thing. I would try what touchyphone said and if that does not work i would restore it and bring it in to apple and have it checked out. just make sure that you have your SHSH's saved in Cydia.
    08-24-2010 06:09 PM
  6. jdcorbitt3's Avatar
    I keep getting these messages too. This is getting old. I think it is a software issue with jailbroke phones.
    Jailbroke and unlocked 4.0.1 iphone 4, cellular and 3g data off. I am cheap. I have a BB Tour the company provides with data. I would love to bluetooth tether data from the tour to the iphone 4.


    John
    Last edited by jdcorbitt3; 09-24-2010 at 03:36 PM.
    09-24-2010 03:33 PM
LINK TO POST COPIED TO CLIPBOARD