1. drensin's Avatar
    iPhone 4, iOS4.
    Sending email works fine from the Mail app. (Pop3) But when sending from, say, the NY Times app -- or any other that allows one to send a link -- I've had a little problem. When I choose "email" (the link) the email form pops up, I fill it in, press send, and return to my original app. But instead of sending, the email goes into the Mail app Outbox. I have to actually open Mail and choose that email and press send again. (Also, even if I delete my standard default Bcc:, because I don't need a copy, the Bcc: will be filled in again when I open the email in the Mail Outbox. I checked various settings but ...?

    How can I fix this?

    Thanks
    Last edited by drensin; 07-22-2010 at 02:02 PM.
    07-22-2010 02:00 PM
  2. touchyphone's Avatar
    Hmmmmm, have you tried reinstalling the apps?
    07-22-2010 02:12 PM
  3. drensin's Avatar
    Thanks for the suggestion. Wasn't the problem. Turns out (hope I can make this make sense): I have two mail accounts for the same email. One uses my home network as the smtp server. The other uses my email provider. The second set up had the problem, but I was using it because my bcc:'s weren't getting stuck in a suspect email box. However it caused emails sent from apps to park in the Mail outbox until I got there and resent. Using the set up with my home network (via my cable provider) does everything correctly, except for the the bcc:'s which get waylaid. Six of one, half dozen of the other. But problem solved. I had set this up this way because on the 3G when I wasn't near my network then emails got hung up because it never automatically went to the next option (att network) ... that seems to work now with iOS4.

    oh -- and of course I only had one of the email setups active at a time.
    07-22-2010 08:23 PM
  4. touchyphone's Avatar
    Hmmmm, this is a weird issue. i know wherever & whenever I send an email from on my iPhone, (and I have multiple email accounts) I can choose which to send from. I assume your issue is solved(says so above). If not, i'll help you troubleshoot still
    07-22-2010 08:48 PM
LINK TO POST COPIED TO CLIPBOARD