1. ZeTaBYTeS's Avatar
    I have upgraded both my iPhone 3G and 3GS to iOS4. Slow performance aside, I notice that whenever I start the Contacts app, the Mail app will auto-check for e-mails in the background (then displays red circle with no. of unread e-mails). I prefer to check for e-mails manually. At the moment, I have 2 e-mail accounts configured for both iPhone 3G and 3GS - Hotmail (POP3) and work mail (IMAP).

    Yes, I have already done this under Settings > Mail, Contacts, Calendar:

    - Fetch New Data > Push > Off
    - Fetch New Data > Fetch > Manually
    - Fetch New Data > Advanced > "mail account name" > Select Schedule > Manual

    And yes, I have terminated all background apps and restarted both iPhone for many times already. Does anyone face this issue? Any solutions?
    Last edited by ZeTaBYTeS; 07-13-2010 at 01:37 PM.
    07-13-2010 01:32 PM
  2. ZeTaBYTeS's Avatar
    Anyone facing similar issue?
    07-14-2010 12:21 PM
  3. iNitvizn's Avatar
    Yes - my 3G started doing the same thing after I upgraded it to iOS 4. I wasn't able to figure out how to stop it either.

    I stopped trying when I got my iP4 - it doesn't happen with my 4.
    07-14-2010 12:29 PM
  4. ZeTaBYTeS's Avatar
    Yes - my 3G started doing the same thing after I upgraded it to iOS 4. I wasn't able to figure out how to stop it either.

    I stopped trying when I got my iP4 - it doesn't happen with my 4.
    Thanks for sharing. iPhone 4 is yet to be available in my country If anyone has a solution to this or similar experience, do share.
    07-15-2010 09:53 AM
  5. ZeTaBYTeS's Avatar
    I think I may have found a workaround on this by changing one of the setting above:

    - Fetch New Data > Advanced > "mail account name" > Select Schedule > Fetch

    Mail app has stopped auto-checking for e-mails whenever I use the Contacts app now
    Last edited by ZeTaBYTeS; 07-17-2010 at 06:18 AM.
    07-17-2010 06:15 AM
LINK TO POST COPIED TO CLIPBOARD