1. sepehrsh's Avatar
    I upgraded my iPhone 3GS to the new 4.0 software, but I now I want to go back to the 3.xx that I had before. Is there any way to do that?
    07-01-2010 06:25 PM
  2. spades1412's Avatar
    Why, are you having problems? iOS4 has been very solid on my wifes 3Gs.
    07-01-2010 06:29 PM
  3. aaronius's Avatar
    Not if you weren't jailbroken and have the SHSH blobs saved.
    07-01-2010 06:43 PM
  4. teryan2006's Avatar
    There's a guide posted on TiPb almost 2 months ago!

    http://www.tipb.com/2010/05/12/howto...iphone-40-313/
    07-01-2010 10:37 PM
  5. JustinHammondPhoto's Avatar
    sweet, i was thinking of putting my 3G back to it because it runs too slow i feel
    07-02-2010 03:03 AM
  6. AZMerf's Avatar
    sweet, i was thinking of putting my 3G back to it because it runs too slow i feel
    My 3G is almost useless under iOS4. Texting is slow, I have to touch buttons several times to get them to work, etc. Given there aren't many comments about this, I am thinking it might be my phone or something else. Anybody got any ideas?
    07-03-2010 04:31 PM
  7. big9erfan's Avatar
    With a 3GS unless you were jailbroken before and tapped "make my life easer" in Cydia you can never downgrade a 3GS
    07-03-2010 05:17 PM
  8. AZMerf's Avatar
    Unless you really want to, I would recommend NOT upgrading to iOS4 if you have the 3G. I've seen the 3GS and it's much better.
    07-03-2010 08:40 PM
  9. AZMerf's Avatar
    Actually, if you're lucky enough to still be under the Apple Care warranty, go to the Genius Bar and ***** up a storm. They will end up replacing it with a refurb that has 3.1.3 on it.
    07-07-2010 11:54 PM
  10. jsntrenkler's Avatar
    There's a guide posted on TiPb almost 2 months ago!

    http://www.tipb.com/2010/05/12/howto...iphone-40-313/
    I have used these instructions to downgrade in the past, they work very well.
    07-08-2010 12:54 AM
  11. BLiNK's Avatar
    My 3G is almost useless under iOS4. Texting is slow, I have to touch buttons several times to get them to work, etc. Given there aren't many comments about this, I am thinking it might be my phone or something else. Anybody got any ideas?
    restore as new and see what happens. i've been reading that has helped a lot with your same issues
    07-08-2010 01:02 AM
LINK TO POST COPIED TO CLIPBOARD