1. dwhatfield's Avatar
    As subject says; wife's 3GS was upgraded. Did a full restore (wipe clean) then synced the backup after installation.

    Not an issue with existing camera roll pics. Those are fine.

    Camera will take pictures....you can then close the camera app, and picture is in camera roll.

    If you choose the pic you have just taken (to MMS, email) an "photos saving" message will appear and never leave. The only way to get out of this is to shut the phone off completely. Upon turning the phone back on, the photo is not in the camera roll.

    If you take a picture, close the camera app, open the camera roll, the picture is there. Shutting the phone off (either by hard reset or using the lock button) then turning the phone back on....no picture.

    I've restored twice, and resynced the backup twice. Same result.

    My iPhone 3GS is having no issues...so you can imagine the glares that I get because I have messed up her phone....

    Thanks to all who reply.
    06-26-2010 07:32 AM
  2. John T's Avatar
    I was sure my 3GS was ok, so, took a photo. Pic appeared in thumbnail on bottom left of Camera setting. On switching to Camera Roll, no picture! Went back to Camera and the picture was still in bottom left!

    Re-booted 'phone. Picture now in Camera Roll. Took a few more test pictures - all seems to be ok now!

    Tried sending one of the pics to myself via MMS. No probs

    I suggest you give your 'phone another re-boot!
    06-26-2010 09:48 AM
  3. Sajidmib's Avatar
    Yes this is a big flaw in the iOS4 i m sick and tired of it... can save any more fotos taken with the camera app... tried restoring couple of times.... it gives complete black spots and sometime picture is deleted coming back out of nowhere.. me n my GF naked

    well whatever the above fix didnt solve it as i see a small thumbnail in the camera of a photo taken but when touch on it it give me the same old foto from Photos app...

    what is happening.
    07-02-2010 11:25 AM