1. teryan2006's Avatar
    I'm having this strange issue that I can't tell it's a feature or what. All my PDF attachments in Mail are now displayed inline in the message, showing the first page only. I can't open them. It's almost like it's treating the pdf as an image.

    Any idea what's going on, or how to get back to the previous 3.x attachment buttons?
    Last edited by teryan2006; 06-21-2010 at 10:10 PM.
    06-21-2010 09:52 PM
  2. skyperbon's Avatar
    I am also having the same problem. It occurred after i upgraded to iOS4. I was not having the problem before this.
    06-22-2010 11:53 AM
  3. Jellotime91's Avatar
    PDFs work fine for me.
    06-22-2010 11:59 AM
  4. JohnH59's Avatar
    My PDF's are showing inline as well. They do that on my iPad too. That's okay except if I decide to send the file to Documents to Go so I can save it to my Dropbox.

    EDIT: After posting this, I double-checked and my PDF's are showing as they should. I'm wondering if installing iBooks made a difference? I can now open the PDF in DocToGo or iBooks.
    Last edited by JohnH59; 06-22-2010 at 02:13 PM.
    06-22-2010 02:02 PM
  5. teryan2006's Avatar
    I tried re-installing iBooks, didn't work. I just noticed if I press and hold on the inline page 1 of the PDF, it popup shows 'Save Image' and copy. It's like mail got confused thinks the PDF is an image. And yes, i checked the attachments are really PDFs. I'm going to do a restore and if it fixes it.
    06-22-2010 02:56 PM
  6. teryan2006's Avatar
    Restore seems to have fixed the problem. From what I read in other forums, looks like the problem has to do with some 3rd party apps not registering correctly as compatible viewer for file formats.
    06-22-2010 03:17 PM
  7. kabe#IM's Avatar
    I have the same problem and a restore didn't help me.
    So please someone.
    What other forums did you find information about this?
    06-22-2010 06:25 PM
  8. Ben428's Avatar
    Restore didn't help for me either. (I'm on a 2G iPod Touch.) Hoping that someone else will post other possible solutions to this thread.
    06-22-2010 08:21 PM
  9. webdude's Avatar
    the solution is mentioned here (and it worked for my case if you follow the steps as mentioned - like you have to delete stanza via itunes etc):

    discussions.apple.com/thread.jspa?threadID=2470587&start=15&tstart=0

    quoting the link:
    1) Connecting my iPhone to iTunes
    2) Removing Stanza in iTunes and do a Sync (thus removing Stanza from my iPhone)
    3) Restarting my iPhone (see note below)

    Now i can open PDF files in emails, and also in QuickOffice (which was also impossible before removing Stanza)

    Note:
    Most of you know, but restarting is:
    Press and hold down the Sleep/Wake button and Home button simultaneously for a least 10 seconds (ignore the slider) but release both the buttons when the Apple Logo appears on the black background. Now wait for the iPhone to restart.
    06-24-2010 05:17 PM
  10. Ben428's Avatar
    The method above worked for me. I also removed Air Sharing, which has been reported as causing problems elsewhere. After completing the rest of the steps, I downloaded Air Sharing again and it continued to work.

    One note: I had to delete the apps from iTunes, not simply uncheck them as some have reported as working elsewhere.

    One odd thing, which is probably related but not a big deal: in the "Open in" dialog for a PDF in Mail, the iBooks logo is appearing on the Air Sharing button, and previously the Air Sharing logo was appearing on the iBooks button.
    06-24-2010 09:34 PM
  11. teryan2006's Avatar
    Also, I think I should note that when I finish the restore, I set it up as a new iPhone, not restore from backup. Doing so from backup will just put the device back to its original state before the restore.
    06-25-2010 06:48 PM
  12. Manu#IM's Avatar
    Hi all;

    I have deleted from iTunes Stanza and GoodReader but still cannot see full PDF attachments in mail (only the 1st page as an image) and cannot export to iBooks.

    Anybody figured out a fix?

    Thanks!
    06-28-2010 06:11 AM
  13. Rob_N's Avatar
    Hi all;

    I have deleted from iTunes Stanza and GoodReader but still cannot see full PDF attachments in mail (only the 1st page as an image) and cannot export to iBooks.

    Anybody figured out a fix?

    Thanks!
    Doesn't work for me either

    It did however work on the ipad
    07-03-2010 03:25 PM
  14. JpNugent's Avatar
    I had the same problem on my wife's iPhone, but not on mine. I even called Apple on it, they told me to restore her phone (a long process as we all know). I asked the Apple tech about iDisk, he didn't think it would make any difference....but it does....it fixed the problem.

    I loaded iDisk on her phone...selected a PDF...sent to iBooks

    Then I emailed her a PDF to test it......and it did NOT download the first page as before. It allowed me to do send it to iBooks or view it, not download it as an image.

    I also had to repeat the process on her iPad.

    All is good in the world of Apple again...atleast for us
    09-05-2010 10:58 AM
  15. bergman's Avatar
    Simply adding quick office solved the problem too.
    09-06-2010 09:42 AM
  16. mockinmaro's Avatar
    My Pdf extensions work fine there may be version conflicts but size doesn't matter.
    01-10-2011 01:23 AM
  17. DusanCarSilni's Avatar
    This method worked for me, too..thnks
    01-11-2011 02:08 PM
  18. Cleveland's Avatar
    Never had this issue at all, interesting, wonder what's causing it....
    01-11-2011 02:35 PM
LINK TO POST COPIED TO CLIPBOARD