1. CaseStreet's Avatar
    I can't hear any sound when I play the ipod on my iphone 2G. I also don't hear any sound when using the phone. The only sound I hear is when I use the speaker on my phone. I also hear sound when I connect my iphone to any ipod dock.

    I've tried restarting but I still have the same problem. Any suggestions.
    05-24-2010 12:20 PM
  2. Guzman's Avatar
    Probably needs to be repaired.

    Maybe SJobs disabled your earpiece and headphone port so you'd buy the new one coming out soon?
    05-24-2010 12:29 PM
  3. CaseStreet's Avatar
    Problem solved. Just blow into the headphone jack. Probably some dust build up. It's always the simple solution.
    05-24-2010 06:38 PM
  4. poisoned10's Avatar
    Not on mine.

    I just had to get a replacement because a similar situation.
    05-25-2010 09:51 AM
  5. Dimwit's Avatar
    had a similar issue with my wifes' first gen iPhone, on her phone, the contacts inside the headphone jack would occasionally stick making the phone behave as if there were headphones installed. our solution was to plug the headphones back in and re-remove them.
    05-25-2010 10:52 AM
  6. rknowlt's Avatar
    Seems like most people already have it nailed for you. Try adjusting the ringer volume using the rocker and see if it comes up as "(headphones)" in the thing that pops up showing the bars of volume. If it does then just clean out your headphone jack and it should fix it. If it doesn't come up like that then you are headed for a genius appointment.
    05-25-2010 02:49 PM
LINK TO POST COPIED TO CLIPBOARD