1. killthelights32's Avatar
    Ok so I am having a really strange issue with my 3GS. When the phone is plugged in the touchscreen gets really buggy. When I try to scroll up and down it jumps up and down spurratically and when I try to select something it will select something totally different.

    When I unplug the phone, it works fine again. Anyone know why this is happening?
    05-16-2010 03:19 AM
  2. Nevets68's Avatar
    The charger your using, is it aftermarket one?
    The reason I ask is because I have a ipod touch and use a "not official" apple charger with it and it does the same thing as yours (ie...weird touchscreen issues).
    05-16-2010 08:59 AM
  3. Chris71's Avatar
    I had the same problem on my 3GS when I was using the aftermarket (ebay) charger, went back to one I purchased at the apple store and the problem went away.
    05-16-2010 09:26 AM
  4. Alli's Avatar
    +1 Not only did I get that problem with an aftermarket charger, but it ruined the battery - drained it in only a few short hours. Thank goodness, the iPhone was only a few weeks old at that point, so Apple was willing to replace it.
    05-16-2010 10:14 AM
  5. killthelights32's Avatar
    The charger I am using is an apple one.
    05-16-2010 02:36 PM
  6. killthelights32's Avatar
    But I am using a usb extension cord (from my Apple keyboard) so I will try not using it tonight and see if that solves anything.
    05-16-2010 05:55 PM
  7. killthelights32's Avatar
    Well I've tried a different charger, different USB cable, but no luck. I will have to make a Genius appointment.
    05-17-2010 01:36 PM
  8. Jellotime91's Avatar
    Hey, killthelights32
    not to be mean, but you might want to edit your posts instead of double-posting.

    There could be dust in your dock connector port. See if you can get some compressed air and use some in there to get dust out. That can really interfere with the connection.
    05-17-2010 02:00 PM
  9. killthelights32's Avatar
    Hey, killthelights32
    not to be mean, but you might want to edit your posts instead of double-posting.

    There could be dust in your dock connector port. See if you can get some compressed air and use some in there to get dust out. That can really interfere with the connection.
    Good to know. Thanks! I had a Genius appointment today at the Apple Store and apparently my battery was a bit defective. I was supposed to be getting around 20 hours of audio playback (I have the iPod playing at work), but I was barely getting 8 hours, so they replaced the unit.

    Problem solved! (I guess)
    05-18-2010 12:48 AM
  10. ghostface147's Avatar
    If all else fails, replace the damn phone.
    05-18-2010 12:59 AM
  11. Jellotime91's Avatar
    Good to know. Thanks! I had a Genius appointment today at the Apple Store and apparently my battery was a bit defective. I was supposed to be getting around 20 hours of audio playback (I have the iPod playing at work), but I was barely getting 8 hours, so they replaced the unit.

    Problem solved! (I guess)
    Haha.. untestable unit problems are always a great way to get a replacement at the apple store. I am so happy that Apple is lenient with replacements. I can't imagine I could've ever walked into an LG store, even in Korea, and got a replacement for my KE970.. hahaha..
    05-18-2010 01:52 AM
  12. killthelights32's Avatar
    I liked how the guys I dealt with described the problem. I want trying to describe it and they ended up calling it seizures. I liked that.
    05-18-2010 02:48 AM
LINK TO POST COPIED TO CLIPBOARD