1. kirkie's Avatar
    I have noticed that I am getting discrepancies in my Calendar when I sync with Outlook.

    For example if I have an appointment set for all day on say the Saturday on Outlook it has been showing up on my iPhone as being on the Friday.

    Has anyone else had this problem and if so how was it resolved?
    04-04-2010 04:15 PM
  2. BENGRIMM's Avatar
    I had this initially when I was switching from outlook to gmail , are you using only one calender ? I think it was how outlook & gmail calender handle the dates and times . Because when I set up my wife's birthday as Sept 21 my phone always told me it was on the 20th . Just run one main calender is my suggestion .
    04-05-2010 03:15 PM
  3. kirkie's Avatar
    I only use 1 calendar and that is Outlook. I put everything in Outlook and then Sync it to my iPhone. Under info on the iPhone I have sync calendars with Outlook checked and then under that I have All Calendars checked...
    04-05-2010 03:24 PM
  4. BENGRIMM's Avatar
    OK , are you just having issues with appointments set up ( ie change oil 3pm to 5:30pm ) or are you having issues with thing attached to contact specifically like Bday or anniversaries ?
    04-05-2010 03:29 PM
  5. kirkie's Avatar
    No issues with Outlook contacts, just things within the calendar. It is just the odd thing on the iPhone shows up a day earlier than it is in Outlook.
    04-05-2010 03:32 PM
  6. big9erfan's Avatar
    Check that your time zones and such are set the same on your computer and in your iPhone.
    04-05-2010 03:41 PM
  7. kirkie's Avatar
    Check that your time zones and such are set the same on your computer and in your iPhone.
    How do I do that please. The clock is the same on my PC as it is on my iPhone.
    04-05-2010 03:43 PM
  8. big9erfan's Avatar
    1. Go to Settings
    2. Go to Mail, Contacts, Calendars
    3. Scroll down to Claendar- Time Zone Support
    4. Change the time zone

    Try changing it if it is incorrect, OR, turn it off completely
    04-05-2010 04:17 PM
  9. kirkie's Avatar
    1. Go to Settings
    2. Go to Mail, Contacts, Calendars
    3. Scroll down to Claendar- Time Zone Support
    4. Change the time zone

    Try changing it if it is incorrect, OR, turn it off completely
    I have just turned it off and pressed sync and I still have things on the wrong dates.
    04-05-2010 05:05 PM
  10. kirkie's Avatar
    I have checked both the iPhone and Outlook and both are showing the right time zone with DST. It is definitely a DST issue as I only noticed it after the clocks went forward an hour.
    04-05-2010 06:31 PM
  11. BENGRIMM's Avatar
    If my memory served me there was an outlook patch that corrected an issue with the DST in outlook since the government decided to change the date of DST a few years back .
    04-06-2010 07:17 AM
  12. kirkie's Avatar
    Any ideas where this is as I am pulling my hair out with it now...
    04-06-2010 03:26 PM
  13. BENGRIMM's Avatar
    Here you go my friend , don't pull your hair out just use a simple goggle search .

    Download details: Microsoft Office Outlook Tool: Time Zone Data Update Tool for Microsoft Office Outlook

    Just as another suggestion you could switch everything over to a GMAIL account and save the hassle of outlook .
    04-07-2010 01:06 PM
  14. kirkie's Avatar
    Already tried that one after I did a search on Google and it hasn't resolved it.
    Last edited by kirkie; 04-07-2010 at 03:01 PM.
    04-07-2010 01:20 PM
  15. kirkie's Avatar
    What I have now noticed is that in Outlook I have my correct time zone and DST checked and on my iPhone I have Time Zone Support off.

    If I put a new appointment in Outlook and click the all day tab and then sync with the Iphone it appears the day before it should be.

    If I then edit the appointment on the iPhone and turn off All-day I see it shows the start time as 23:00 and ends 00:00 so that is either a 1 hour appointment or a 25 hour appointment and not 24 hour which would be All-day...
    04-12-2010 05:23 PM
  16. kirkie's Avatar
    04-12-2010 05:32 PM
LINK TO POST COPIED TO CLIPBOARD