1. fidesachates's Avatar
    Hi,

    I have an iPhone that's updated on the latest software updates. I'm syncing to my Exchange account so I rarely sync with my computer. The issue is that some of my folders don't sync correctly with the exchange over 3g or wireless. My inbox always syncs, but my trash and sent folders are blank when i click into them. Also, I have a folder under the inbox that never syncs.

    My co-worker is also experiencing this issue. Is there a workaround? Please note that I don't have access to the exchange server as it's managed by my company's email group.

    Thanks in advance for any help given.
    03-22-2010 03:13 PM
  2. anon(153966)'s Avatar
    Even after clicking said folder on the iPhone, and waiting a minute or two, it never populates with email?

    As a test, create a new sub-folder in the Inbox, move a few items to it and see if it syncs. If it does, move all those items from the non-syncing folder to it...
    03-22-2010 03:29 PM
  3. fidesachates's Avatar
    Even after waiting it does not. The new folder option does work, but it's temperamental (I've tried it before). After a while, it'll simply stop syncing again. Sometimes my sent folder will sync, but it'll be empty two weeks later (I think it syncs sometimes, and later, when it doesn't, it knows there are more recent messages, so it deletes the messages on the phone, but it never correctly grabs the more recent messages).
    03-22-2010 03:48 PM
  4. anon(153966)'s Avatar
    I say remove the said email account and re-add it...

    Also, do you have wifi on? I wonder if that's a factor, too...
    03-22-2010 04:00 PM
  5. mullrat's Avatar
    Have you tried creating a rule in exchange? Like a rule on the subfolder that will copy the email to the folder if it is from person X.

    I've noticed that folders only seem to sync when you create it after the initial sync. So what I would do is create a new folder like @sent and create a rule that says copy all email from sent to @sent. You should be able to see it after that.

    hope this helps.
    03-22-2010 04:07 PM
  6. fidesachates's Avatar
    I say remove the said email account and re-add it...

    Also, do you have wifi on? I wonder if that's a factor, too...
    Yea I thought maybe the data was simply too much for the sync on 3g, so I turned on wifi, but still no luck.

    Also my co-worker has removed the account and re-added, but over time the problem will come back. It fixes it initially, but not permanently.

    Have you tried creating a rule in exchange? Like a rule on the subfolder that will copy the email to the folder if it is from person X.

    I've noticed that folders only seem to sync when you create it after the initial sync. So what I would do is create a new folder like @sent and create a rule that says copy all email from sent to @sent. You should be able to see it after that.

    hope this helps.
    I'm sorry. I'm a little confused to your suggestion. So you're suggesting I create a rule on the Exchange Server that copies/moves all messages from one folder to another one that I've just created. And your theory is that because the new folder is created after the initial setup, it will sync.

    If that's the case, could I simply create a new folder, move all mail to that folder, and redirect any current rules to the new folder? I understand you can't do this with the sent and trash folders since they aren't created by the user in Exchange.
    03-22-2010 08:11 PM
  7. anon(153966)'s Avatar
    Does your Exchange server support SSL? If yes\no, is it on\off on your iPhone at present? Either way, switch it, and see what happens...
    03-23-2010 07:19 AM
  8. fidesachates's Avatar
    Does your Exchange server support SSL? If yes\no, is it on\off on your iPhone at present? Either way, switch it, and see what happens...
    My server does support SSL. My iPhone had it on. However, on a whim, I decided to turn SSL off. Naturally my Inbox stopped syncing and all the folders disappeared. When I turned it back on, the mailbox still wouldn't sync. A soft reset brought my mail back and surprisingly all my folders now sync.

    I'm doubtful a switch between on/off of the SSL option fixed it. I'm chalking it up to the soft reset even though I've done that before.
    03-23-2010 03:20 PM
  9. anon(153966)'s Avatar
    Whatever it takes
    03-23-2010 04:01 PM
  10. bubbatex's Avatar
    Go to Settings > Mail Contacts and Calendars > Select your Exchange account > Look down the page until you see "Mail Folders to Push" and there you will find the only folders you can sync. I sync Inbox, Sent Items and Deleted Items.
    03-24-2010 02:38 PM
  11. Hoku Lanee's Avatar
    My coworkers are having this issue also... Have you also tried going in and telling Mail Days to Sync? I found that was my problem. On my iPhone, Mail Days to Sync was set to only 3 days. I have reset it to No Limit and now see all the emails in my subfolders. I've also went into Push and selected which subfolders I wanted to sync.
    06-19-2014 02:55 PM
LINK TO POST COPIED TO CLIPBOARD