1. troy9129's Avatar
    Is it possible to disable apple.com, imap, and any other applications that my IPhone 3GS is trying to run in the background? I am using a server with very limited bandwidth and I can see on the router log that these applications are always running and I think it is bogging down my email. The only thing I want to do is access my company email and possibly gmail.
    02-15-2010 03:22 PM
  2. flyingember's Avatar
    You want to disable imap but want to keep email.

    Stop doing what you're trying and go learn how email connects...

    Also, what is your server?
    02-15-2010 03:46 PM
  3. troy9129's Avatar
    Okay, maybe not imap, but definitely apple.com. I am just learning the IPhone but I see a big difference in the way the BB and ITouch work with this server.

    Can I keep the IPhone from going to apple.com, or if I accidently hit the Apps store or the Itunes store? I only want to access my compnay email.
    02-15-2010 03:59 PM
  4. Earless Puppy's Avatar
    turn off WiFI
    02-15-2010 04:07 PM
  5. big9erfan's Avatar
    turn off WiFI
    That won't keep it from connecting to the app store.

    I know of no way to keep the iPhone from connecting to apple.com if you open up the App Store or ITunes.
    02-15-2010 04:23 PM
  6. troy9129's Avatar
    I don't want to go to any of these sites, thats the problem. My IPhone automatically goes to apple.com and then I accidently hit the apps store and it was trying to go there.

    I have to use the Wi-Fi and I only want to go to my company email. Because the IPhone is trying to go these other sites, it is slowing the whole thing down and me emails are failing because I have very limited bandwidth.

    Blackberry and ITouch work great because they do not pull up all this other stuff.
    02-15-2010 04:31 PM
  7. big9erfan's Avatar
    You can't stop it from going there if you accidentally go to the Apps store.

    I'm not sure why it is going to apple.com in the background other than that, are you 100% sure it is your iPhone and not iTunes on your computer checking for updates?
    02-15-2010 04:57 PM
  8. troy9129's Avatar
    Nope, the computer that I am checking the router with does not have Itunes.

    So I will keep it simple.

    How do I keep the IPhone from going to apple.com in the background?
    02-15-2010 05:05 PM
  9. big9erfan's Avatar
    I'll check when I get home to see if my iPhone does this, but I'm not aware of the iPhone going to apple.com in the background.

    Is the phone being used during the time the router logs the requests or is the phone in standby ( screen off, not being used )?
    02-15-2010 05:15 PM
  10. troy9129's Avatar
    Both Stby and Active.
    02-15-2010 05:50 PM
  11. big9erfan's Avatar
    I just dug through my works wireless logs. I noticed a total for 4 requests from iPhone to an apple server for the entirety of the day ( 8am - 3pm so far ) one was to metrics.apple.com and one was to some iTunes address. I may have opened up the App store once today, I don't recall, but it is NOT sending out constant data.

    Secondly, wifi turns off when the iPhone goes into standby so it cannot continually send out requests through your network.
    02-15-2010 06:12 PM
  12. troy9129's Avatar
    The problem is much greater when I first connect so when it initially goes to apple.com, that may be the reason.

    I didn't realize it turns off the Wi-Fi when it goes to Stby. That may be another reason for the problems. When I come out of Stby and reconnect the Wi-Fi, would there be another attempt to go to apple.com?
    02-15-2010 06:28 PM
  13. big9erfan's Avatar
    I can't duplicate your issue of the phone going to apple.com when I just wake it up. The only time I see it going there is if I go to the App Store or ITunes. I don't know why you are seeing what you are seeing.

    Is your iPhone jailbroken?
    02-16-2010 11:09 AM
  14. flyingember's Avatar
    do you have push enabled for anything?
    02-16-2010 04:39 PM
  15. troy9129's Avatar
    Not jailbroken.

    Yes, it is set for Push, should it be?
    02-17-2010 12:13 PM
  16. big9erfan's Avatar
    You could try turning off push and see how it works. You could also turn off Wi-Fi all together and your iPhone won't use your local network at all anymore.
    02-17-2010 03:15 PM
  17. troy9129's Avatar
    If I turn off Wi-Fi I can't connect to the router.

    I think I found my solution. On the Restrictions page, I can turn off Safari, Apps, and a whole lot more. This seems to have solved the problem as it is only doing email.

    Thanks,
    Troy
    02-17-2010 03:20 PM
  18. big9erfan's Avatar
    Why do you need it connected to the router?
    02-17-2010 03:23 PM
  19. troy9129's Avatar
    I am using a wireless router that is connected to a satellite transceiver onboard a corporate aircraft. I need to turn aircraft mode on and the Wi-Fi on to connect to the router which uses the transceiver to send email. It works great with Blackberry and ITouch because they aren't using very much bandwidth. The IPhone fails because it is constantly looking for updates and pulls so much bandwidth.

    Those previous settings aren't working for everyone at the moment.
    02-17-2010 04:46 PM
  20. big9erfan's Avatar
    Would it be possible to just block any requests at the router to an apple.com address?
    02-17-2010 06:57 PM
  21. troy9129's Avatar
    Possibly, but I am not sure howthe phone might handle that. It may give error messages or lock it up because it will continuously be trying to get to apple.com.
    02-18-2010 10:04 AM
  22. big9erfan's Avatar
    I'm really not sure what else to suggest here. I can't replicate the issue to suggest what you might be able to do to the phone to disable it. Perhaps it's time to make a call to apple support.
    02-18-2010 11:41 AM
LINK TO POST COPIED TO CLIPBOARD