1. jnickell's Avatar
    I can't seem to find anything about this in the forums. I've had my iPhone for a few months, but whenever I'm on wifi Youtube videos don't work. If I disable wifi, it works fine. It's not just one wifi either - any wifi I have had a chance to try it on thus far. Anyone got any fixes?

    Thanks!
    12-27-2009 08:27 PM
  2. Earless Puppy's Avatar
    will safari work on Wifi?
    12-27-2009 08:28 PM
  3. jnickell's Avatar
    Yep, everything else works great on wifi. No other issues with the rest of the phone.
    12-27-2009 08:30 PM
  4. Earless Puppy's Avatar
    are you trying the same youtube video or different ones?
    12-27-2009 08:32 PM
  5. Earless Puppy's Avatar
    sorry about the stupid questions, but they may help myself or someone else narrow down your problem
    12-27-2009 08:33 PM
  6. jnickell's Avatar
    No problem, I just tested a few things and should clarify anyway. Every few video's will load okay, but most load endlessly or ridiculously slowly. Swap to 3g and it works great. The featured or most viewed seem to have a higher likelihood of loading. I seem to get the cannot connect to YouTube error a lot too. I can stand right next to my friend with a iPod Touch on the same wifi and his downloads lightning speed and mine will load endlessly.
    12-27-2009 08:45 PM
  7. Earless Puppy's Avatar
    reset all network settings (you will have to reenter any wifi passwords) see if this helps
    12-27-2009 08:55 PM
LINK TO POST COPIED TO CLIPBOARD