1. eldiablojoe's Avatar
    I don't understand. My iPhone has worked GREAT since I got it in July 09. It is a 3GS 32GB, with most recent firmware. I synced recently, like 2 days ago, without issue.

    I went to check it about 30 minutes ago, like I do dozens of times per day, and it is completely black-screened. No logo, no nothing. It is like it is still in sleep mode. I've pressed and held the Home button, nothing. I've pressed and held the button on the top right of the cell, nothing. It's completely unresponsive. I plugged it into an Apple wall charger hoping to jar it back to life like an AED, but nothing- Not even the usual chirp or buzz I get when I plug in the charger to the phone.

    Any ideas anyone?

    Thank you!!!
    12-24-2009 12:47 PM
  2. big9erfan's Avatar
    When you plug it into a computer with iTunes does it recognize it?
    12-24-2009 01:03 PM
  3. eldiablojoe's Avatar
    Dunno, I'm not at home or at a computer with iTunes.

    Awesome, I did just that and it worked!!!! Apple Support walked me through it. I didn't lose any texts, or contacts (that I can tell), all my apps and settings are the same. Awesome!!

    I pressed and held the home button, while I pressed and held the button on top of the phone for 10-15 seconds until the Apple logo appeared. Then I let go and set the phone down to let it turn itself on for 60-90 seconds.

    Then it was A-ok!!
    12-24-2009 01:20 PM
LINK TO POST COPIED TO CLIPBOARD