1. Jaguars55's Avatar
    I just got a new 3GS and set up my yahoo email on it. When I open the mail app, it loads all the emails and then immediately starts removing them. Even if I open one of the emails, it just keeps removing them from the screen and then gives the "Load More Messages" display. I've tried deleting the account and reloading it and the same thing keeps happening. Any ideas?
    12-11-2009 01:17 AM
  2. Jaguars55's Avatar
    Well, I've also tried restoring the iPhone and I'm still having the same problem. Anyone have any ideas what may be causing this?
    12-11-2009 03:29 PM
  3. g1r_g3n1us's Avatar
    by removing do you mean deleting?? or do you mean exiting the message when you press it.
    12-11-2009 03:51 PM
  4. flyingember's Avatar
    do you have any mail rules setup on the yahoo account to move email to folders?
    12-11-2009 04:01 PM
  5. Jaguars55's Avatar
    It's not deleting them, it loads all the messages and then just starts taking the messages off the screen until there are no messages still visable and then giving the "Load Messages" button. And I don't have anything set up on Yahoo to move anything to folders. This is really driving me crazy, I had a 3G and never had any real issues with it and I've never seen anything like this.
    12-11-2009 05:04 PM
  6. dragonsgoalie's Avatar
    I've seen this on my phone at times. It seems to be a problem sync-ing with the Yahoo server. I look at the emails and it's like they just disapear, then after a while they just come back. You could check your preferences for the account like the person said above and make sure you don't have your "Delete after X days" set too low?? Try setting it to "Never" and see if the emails stay.
    12-11-2009 11:16 PM
LINK TO POST COPIED TO CLIPBOARD