1. MustangLife's Avatar
    I woke up this morning and messed around didn't have to rush to work. And realized my phone was an hour behind somehow. I know last night it was on point cause I watched CSI Las Vegas on time and looked at the phone. I had this issue when the time change occurred and I had to turn off auto time and turned off 3g and than turned the auto time back on and it fixed it. The date is correct also. I can ignore anything that only happens once but now thats its twice now. I'm concerned. I'm on 3.1.2 on a 3GS 16GB.

    Thanks
    Josh
    11-13-2009 10:17 AM
  2. jglowe74's Avatar
    unless you traveled through different time zones, just discovered it had switched to DST, or you have stumbled upon a wormhole that alters time, i don't know the answer to this one. any chance the phone is set to DST and you are not actually IN a DST zone? or maybe on some weird chance the 3G network is configured differently than the Edge/O2/whatevernetworkyouareon? this is indeed a weird one.

    which JB did you use? blackra1n? pwnagetool?
    11-13-2009 10:24 AM
  3. MustangLife's Avatar
    Don't know the complete answer to your question. I do know as soon as I turned the automatic time off it switched to the right time. I turn it back on and it stayed on the correct time. I didn't go out of my time zone in about 7 or 8 days.

    Josh
    11-13-2009 10:40 AM
  4. jglowe74's Avatar
    sorry josh, i was just being sarcastic in my last post. i do find it odd that switching on/off the 3G fixes the issue. i hate to even mention it, but you might want to do a restore through iTunes. as much as i despise them, restores really do solve all of my problems.
    11-13-2009 10:50 AM
  5. MustangLife's Avatar
    Ha, I knew the sarcasm part. I meant about the DST. This time I didn't have to turn off 3G just the time part. Turning off 3g is something I always do when theres something going on (issue wise) but your still probaly right I might need to do a restore.

    Another thing to mention. The previous day my phone did go dead on me in the middle of the night. I was running a sleep noise app without charging the phone and woke up in the morning to a dead phone. This was 24 hours prior to the time issue.
    11-13-2009 10:56 AM
LINK TO POST COPIED TO CLIPBOARD