1. gatorinmn's Avatar
    Anyone else have this problem? I am running a 3GS on the latest software upgrade (I forget which version). If I open a webpage on Safari and then navigate to a different one, I don't have a "back" button to go back to the previous page. The left arrow is visible at the bottom of the screen, but it is grayed out -- I can't click on it. Anyone ever have this problem or have a fix?
    11-01-2009 09:13 PM
  2. wabbit#IM's Avatar
    maybe due to the fact the page opened a new tab, look on the bottom right see if you have the old page as a tab.
    11-01-2009 09:16 PM
  3. dawggg63's Avatar
    The number inside the pages at the bottom right of the screen show you how many pages you have open. Tap on that, and you can flip between open pages (or close them).
    11-01-2009 09:51 PM
  4. jcampbell1070's Avatar
    i had that problem awhile back and i just ended up restoring as new and i never had that problem again. so far
    11-02-2009 12:46 AM
  5. gatorinmn's Avatar
    No, it's not new tabs. It's in the same tab -- the back button just isn't there when I go to a new page. It's as if Safari is forgetting my history when I go from page to page.

    Glad to hear someone else had the same problem, jcampbell, although I'd prefer not to have to restore my phone as new and lose all my contacts, settings, etc. Was hoping for a better solution. Anyone? Bueller?
    11-04-2009 10:38 PM
  6. Ipheuria's Avatar
    would say take a screenshot it might help everyone visualize the problem.
    11-04-2009 11:36 PM
  7. jcampbell1070's Avatar
    befor i done a restore as new i done a hard reset and that cleared up the problem for a few days but it the problem still came back. so i just done a restore and it fix it but there might be another way around it and i dont know thanks
    11-04-2009 11:55 PM
  8. Hack-My-i's Avatar
    Anyone else have this problem? I am running a 3GS on the latest software upgrade (I forget which version). If I open a webpage on Safari and then navigate to a different one, I don't have a "back" button to go back to the previous page. The left arrow is visible at the bottom of the screen, but it is grayed out -- I can't click on it. Anyone ever have this problem or have a fix?
    i also lost the 'back' button...and NO its not a new page! when i click on a link, i cant go back!
    11-05-2009 12:26 AM
  9. gatorinmn's Avatar
    This problem had disappeared for me a few days after my initial post, but it reappeared after I synced last night. Anyone have any thoughts?
    12-14-2009 12:15 AM
  10. g1r_g3n1us's Avatar
    try removing your cache and doing a soft reset. which is holding down home/power til the apple logo comes back on (usually about 8-10 seconds).

    This removes any applications running in background. if that doesnt help, it might be a issue with your safari. try going and asking at the genius bar..
    12-14-2009 11:50 AM
  11. flyingember's Avatar
    sometimes pages can remove the back button capabilities. I'm not sure if it's true in this case but there is javascripting that can do this I believe.

    does this happen randomly or always on the same site?

    if the latter, could you post the specific site?
    12-14-2009 12:13 PM
  12. Hack-My-i's Avatar
    noo...it happened to me too, i reJB and no more issues...it happens on every page flyingember, it had nothing to do with the page
    12-14-2009 01:31 PM
LINK TO POST COPIED TO CLIPBOARD