1. iBoxtaboy's Avatar
    Hi all. I have a 3GS, and notice an email notification problem. I have a yahoo and gmail account on push, and 4 other email accounts on fetch. I had thought that with any new email that comes in (whether pushed or fetched to the phone), you should get a notification to your home screen dock email icon. Instead, I have to go open the email app, and then the notification pops up that I have several emails. Why?

    Isn't it supposed to let me know I have emails waiting for me from the home screen? I don't want to have to open my email application everytime to see if I have any new emails. Is there a setting I can do to fix this? Thanks for any help.
    10-06-2009 09:11 AM
  2. sting7k's Avatar
    Well Gmail has been going on and off with push for me the past few days. If you don't get one pushed and open the app it checks them all so anything that got messed up or hasn't been sent in your fetch period will get delivered then.
    10-06-2009 09:14 AM
  3. iBoxtaboy's Avatar
    Well Gmail has been going on and off with push for me the past few days. If you don't get one pushed and open the app it checks them all so anything that got messed up or hasn't been sent in your fetch period will get delivered then.
    Thanks, but this is happening to me within my Yahoo account. Btw, I didn't set up my Yahoo account for push the same way as with Gmail (thru an Exchange server). Is that the issue? The Yahoo account setting in my phone shows as "push" though.

    Also, in my mail settings, I pulled up a page where it shows SMTP settings, and it is ON for my Yahoo SMTP server, but OFF for my gmail, aol, live, and AT&T SMTP server accounts. Is this the right setting? Yahoo is my primary server.
    Last edited by iBoxtaboy; 10-06-2009 at 09:25 AM.
    10-06-2009 09:18 AM
  4. iBoxtaboy's Avatar
    Ok, another question- when I go into the SMTP page in my settings, it shows that the primary server I chose is the yahoo SMTP server. There is also a section below it showing Other SMTP Servers (which contain 5 other email servers that constitute my 5 other email accounts either pushing or fetching to the phone). For those settings, they are set at OFF. So, only the primary server is switched on. Is this this the correct setting, or should I turn all of the other SMTP servers to ON?

    Thanks in advance.
    10-06-2009 10:04 AM
  5. BENGRIMM's Avatar
    My yahoo has not been pushing my emails for about a week now . I wonder what is going on .
    10-06-2009 11:49 AM
  6. iBoxtaboy's Avatar
    My yahoo has not been pushing my emails for about a week now . I wonder what is going on .
    Ok, well, I rebooted my phone and now the Yahoo account is pushing to my phone normally again. Guess this is sorta like doing a battery pull on a Blackberry. LOL
    10-06-2009 12:02 PM
  7. Greg Orlando's Avatar
    I need to check my emails in every one hour.And Gmail always keeps me waiting for at least 1-2 minutes.Push Gmail is really slow.So I would suggest you to leave push Gmail and go for Gmail through exchange.
    10-07-2009 03:55 AM
  8. iBoxtaboy's Avatar
    I need to check my emails in every one hour.And Gmail always keeps me waiting for at least 1-2 minutes.Push Gmail is really slow.So I would suggest you to leave push Gmail and go for Gmail through exchange.
    Sorry if I wasn't clear...I actually do have Gmail set up to push to my phone through exchange. I didn't even know you could set up Push Gmail on the iPhone. Thought it would automatically be set up as fetch, and that the only way to get push Gmail was by doing it through an exchange server.
    10-07-2009 11:42 AM
  9. cobra302's Avatar
    dont feel bad, i've got mobile me and have the exact same problem. its been happening to me more lately, i'll notice that i dont have any new email, open the mail program, and the phone starts beeping because all my emails are coming in. yahoo works fine, but mobile me isnt. i chatted with support a few weeks ago, and i'm gonna do it again here in a sec. i end up having to go to the email settings, turning push off, then back on. the emails start showing up after that. i wonder if its something to do on a server end somewhere. i cant see this being a phone issue.
    10-07-2009 03:46 PM
  10. mister_getdown's Avatar
    Bumping this thread out of sheer frustration. I'd hoped that one of the last few updates would've fixed the fetch and push problems on my 3G, but it's only gotten worse as far as consistency is concerned. Now, I get about one alert of new mail a day if I'm lucky even though I'm receiving new mail all day long.

    How is everybody else faring? Anybody happen to find a fix?

    (For the record, I have a Yahoo mail account set to push and a Gmail account still set to fetch every few minutes. Neither are working.)
    10-22-2009 12:45 PM
LINK TO POST COPIED TO CLIPBOARD