1. dragonsgoalie's Avatar
    Does ANYONE know how to roll back to an older software version? I lost my tethering with the 3.1, and cannot reinstall it. Plus there is nothing really in 3.1 I care about. Just want to go back, and have my tethering back.

    iPhone 3G, Not JB, or Unlocked!

    Thanks!
    09-23-2009 10:30 PM
  2. shutter's Avatar
    I do not believe you can if you never had your signed files captured. Apple stopped signing 3.0 and 3.0.1 software the day 3.1 went live.
    09-23-2009 11:08 PM
  3. dragonsgoalie's Avatar
    Thanks....
    09-24-2009 07:49 AM
  4. huesie's Avatar
    Does ANYONE know how to roll back to an older software version? I lost my tethering with the 3.1, and cannot reinstall it. Plus there is nothing really in 3.1 I care about. Just want to go back, and have my tethering back.

    iPhone 3G, Not JB, or Unlocked!

    Thanks!
    Sorry I can not post a link as this is my first official post after lurking for several months. I have downgraded my iPhone 3G from OS 3.1 to OS 3.0 by following the guides I found in various forums. In addition to the IPSW for OS 3.0 you will need to download the iRecovery for either MAc or Windows. This is because baseband was upgraded in OS 3.1 and restore sees and 1015 error when downgrading. There are multiple guides to assist you.

    After downgrade I was able to use the benM hack to tether again. The downside is that the modem firmware (baseband ) was upgrade to 5.11.07 I think and could not be rolled back to OS 3.0 version.

    If you are daring after downgrade to 3.0 you could JB using redsn0w and then install fuzzyband to see if you can downgrade baseband to 3.0 version. This would help if you ever wanted to unlock your iPhone....say to sell at later date. Fuzzyband only works if you have 5.08 bootloader and the GUI interface will tell you if it is possible to downgrade. Most 3G have bootloader 5.09 which at the current time can not be downgraded.

    Good luck
    09-24-2009 08:01 AM
  5. ben252's Avatar
    I managed to roll back to 3.0.1 yesterday as I'd lost the ability to send MMS messages on 3.1 so it can be done.
    09-25-2009 05:29 AM
LINK TO POST COPIED TO CLIPBOARD