1. obee1's Avatar
    I just set up home sharing on both my spouse's and my computer, but in our setup, unlike in the demo at Apple's music event, "Applications" don't show up as sharable.

    Music, Movies, TV Shows, Playlists...everything, except for Apps, shows up.

    Am I missing something? Was that option pulled from iTunes 9, but they forgot to tell the guy doing the presentation?
    09-15-2009 10:37 PM
  2. Ipheuria's Avatar
    What firmware is on both your phones? I haven't tried using Home Sharing yet so can't really help you out. I know the re-arrange function for the Iphone screens only works with a combo of 3.1 and Itunes 9 so maybe it's the same for sharing the Apps. I'm sure someone else will come in and clear it up soon enough.
    09-15-2009 11:13 PM
  3. obee1's Avatar
    Neither of us has upgraded to 3.1 yet. It would be sharing between computers though, whereas that app arranging through iTunes directly uses the phone, so I could see that needing your phone to be on the latest version. I don't think home sharing between computers would know or care if your phone is updated.
    09-15-2009 11:25 PM
  4. Allyson Kazmucha's Avatar
    I do not believe apps are a part of home sharing. That's the problem. if you want to share apps, just log into the same iTunes accounts on your phones and computers.
    09-16-2009 12:12 AM
  5. iownaniphone's Avatar
    I used home sharing last night to share my NFS game. We both had our own apple store accounts, but used my username for the home sharing. Once she was connected, all she had to do was click the little arrow/triangle next to "John's Library" and a drop down list appears similar to my own itunes menu list. Applications showed up just fine and all she had to do was drag it (NFS) to her library. *Note: the arrow only appears once the other person's library is fully loaded.
    If it's any help, we both have itunes 9. I have the iphone 3gs 3.1 and she has the 3gen touch 3.1. I dont really think the device has anything to do with it though.
    09-16-2009 12:19 AM
  6. Allyson Kazmucha's Avatar
    I used home sharing last night to share my NFS game. We both had our own apple store accounts, but used my username for the home sharing. Once she was connected, all she had to do was click the little arrow/triangle next to "John's Library" and a drop down list appears similar to my own itunes menu list. Applications showed up just fine and all she had to do was drag it (NFS) to her library. *Note: the arrow only appears once the other person's library is fully loaded.
    If it's any help, we both have itunes 9. I have the iphone 3gs 3.1 and she has the 3gen touch 3.1. I dont really think the device has anything to do with it though.
    hm, interesting. i didn't know that. i haven't messed with it yet as i haven't had time, but since they only demoed music, i guess i just assumed they would have said it worked with apps, that's good to know though.

    so op, as he said, it could take a while to load, if you have a pretty extensive collection on either computer, so make sure you're letting everything load, especially if you're running off wifi, which is obviously a bit slower at loading than something hard-wired.
    09-16-2009 12:23 AM
  7. iownaniphone's Avatar
    One more thing. Under preferences and the Sharing tab, I set mine to share my entire library. If you choose the other option "share selected playlists," applications isnt even on that list. Strange huh
    09-16-2009 12:32 AM
  8. obee1's Avatar
    Thanks for responding, but it's no go. It's set to share entire library and the it is completely loaded. In fact, it doesn't show song one until the loading process is complete, so it's not that. I click the triangle and it shows Movies, Music, TV Shows, Podcasts, Playlists. No Applications selection available.

    @ Iownaniphone: Are you using Macs or PCs. Not sure if that would make a difference or not, but in the demo he used a Mac and I'm using a PC. Maybe it's PC discrimination or something.

    On another note: In the demo he has a bar that you can choose to filter and show only songs that are in their library and not in yours. That bar doesn't exist in my iTunes. The iTunes he demos and the one in my computer have some major discrepancies. If they hobbled the Windows version of iTunes, they should've mentioned the features were "Mac only" in the demo. If they didn't hobble the Windows version, then I have no idea why features he shows aren't working in my or my wife's copies of iTunes.
    09-16-2009 06:28 PM
  9. Ipheuria's Avatar
    Apple - iTunes - Learn about the features of iTunes 9.

    From the site - With Home Sharing, you can share music, movies, TV shows, apps, and more among up to five authorized computers in your house. To set up your Home Sharing network, just sign in to your iTunes account from each computer you want to add. Then browse all the iTunes libraries on the network and import your favorites. You can also choose to have iTunes automatically import purchases made on any of the computers to your own library.

    I tried the home sharing with a friend at work today and noticed that it didn't show the apps either. Then I double clicked one of his songs to play it and it asked me to sign in and authorize in order to play the song. I haven't tried it yet but I beleive you have to sign in to home sharing on both computers with your Itunes user not two different users. I'm also using a Mac and I thought maybe it was different between Mac and Windows but that just doesn't make sense. I'll try it tonight but if you try it and it works let us all know.
    09-16-2009 07:02 PM
  10. obee1's Avatar
    Hmm...I tried playing one of her songs on my computer earlier and it started up fine. It didn't say anything about authorizing the account.

    Just the same, I gave it a try. I signed into my account on both hers and mine and even authorized her computer with my account and had her do the same. Still the same...no Apps sharing.

    If someone hadn't come on saying that they did it, I'd be thinking that they pulled the feature upon release. Kind of strange that I haven't heard anything about the feature's absence on any of the iPhone blogs I frequent.
    09-16-2009 10:14 PM
  11. Ipheuria's Avatar
    WOW that is so weird. I wasn't able to try it with my GF today since she had school. So once I try it tomorrow if I figure out anything I'll post up.
    09-16-2009 10:19 PM
  12. obee1's Avatar
    Finally got it working. Sorry Ipheuria...I'd misread your last post. Kind of unintuitive, but you do have to go on both computers and enable home sharing using the same screen name and password on each.

    Previously she'd (logically) signed up for home sharing on her computer using her account and I'd signed up on mine using my account.3

    The instructions probably could've been worded better, but since nobody else has been talking about it, I'll assume I'm in the minority in not getting what they were saying.

    Thanks for the help Ipheuria.
    09-16-2009 10:29 PM
  13. iownaniphone's Avatar
    im using a PC and shes using a MAC..

    holy crap.... i just tried getting some of my sister's apps.. no go..

    apple screwed PC users!!!! grrr
    09-17-2009 12:06 AM
  14. Allyson Kazmucha's Avatar
    im using a PC and shes using a MAC..

    holy crap.... i just tried getting some of my sister's apps.. no go..

    apple screwed PC users!!!! grrr
    It's a Steve conspiracy, Steve jobs wants you to stick it to steve ballmer and get a mac.

    Not but in all seriousness, I don't think PC or Mac should matter with home sharing, i don't "think" apple would be that stupid as to exclude windows users from certain vital features. I would think it's more of a setting. Make sure there isn't a privacy setting in either of your iTunes that is preventing you from copying or transferring. Also, do you have the same iTunes account logged into BOTH computers? You can't do it with 2 separate iTunes accounts.
    09-17-2009 12:32 AM
  15. obee1's Avatar
    They are two separate iTunes accounts, but you can still share everything. They made it pretty complicated though.

    If your computer is computer A and the other person's is computer B, you first need to authorize your account on computer B. Go to "Store" and click "Authorize Computer." For user name enter computer A's account name and password (i.e. your account info). Then you select sharing on computer B and again use the account name and password of the account on computer A (i.e. your account info). Turn on computer sharing on computer A once more using your account name (the same that you used for sharing on computer B). You can then transfer items between accounts and "Applications" will show as an option.

    I also authorized computer B's account on computer A, but I'm not positive that that was necessary. Now that it's working, I'm not messing with it though. They really need a better walkthrough for this setup. I can't believe more people aren't having issues. A lot of people don't seem to know about it or exactly how it works though.
    09-17-2009 02:44 AM
  16. Ipheuria's Avatar
    Glad you got it working, that's how I figured it would work and glad you now explained it for any future askers. Sorry I know I can be a bit confusing LOL I usually re-read my post before I hit submit. So now you have to figure out the setting that transfers any newly purchased apps, music, etc. from the master library automatically that would be a cool thing and require less work on the users part. Yeah I know alot of my friends thought that apps wasn't part of the home sharing so I think alot of users just don't know.

    Iownaniphone, like iMuggle said I doubt the Windows version of ITunes would leave out such an integral functionality. So give it a try again.
    09-17-2009 08:21 AM
  17. iownaniphone's Avatar
    yeah, i was thinking about it while trying to sleep.. it really bothered me that i wasnt able to do that... i thought we got screwed
    i actually realized, while laying in bed, that i never authorized my computer to use her account.
    ill try that today, hopefully it works. thanks for the input guys (and girls)
    09-17-2009 11:31 AM
  18. CYaris's Avatar
    Ok, I tried everything listed here, and my wife's computer shows up under share for me, but my computer doesn't show up for her. There is nothing under shared.

    Weird.
    09-17-2009 02:27 PM
  19. CYaris's Avatar
    Oh, and applications isn't even a possibility on mine. Doesn't show up under shared.

    What am I doing wrong?
    09-17-2009 02:28 PM
  20. Pr3mier's Avatar
    okay... hope this helps.
    i assume you both use separate accounts for itunes?

    1. I dont know if this needs to be done, but under preferences > sharing tab, select "share entire library"
    2. turn on home sharing for both computers. use one username for both computers for home sharing.
    3. authorize your account on her computer and authorize her account on yours. if you are using windows, it is under store > authorize computer

    as others have said before, the drop down list only appears after the other person's library has fully loaded onto your itunes

    good luck
    09-17-2009 10:08 PM
  21. obee1's Avatar
    okay... hope this helps.
    i assume you both use separate accounts for itunes?

    1. I dont know if this needs to be done, but under preferences > sharing tab, select "share entire library"
    2. turn on home sharing for both computers. use one username for both computers for home sharing.
    3. authorize your account on her computer and authorize her account on yours. if you are using windows, it is under store > authorize computer

    as others have said before, the drop down list only appears after the other person's library has fully loaded onto your itunes

    good luck
    Good job simplifying my convoluted explanation. Only correction is that people have to switch step 3 and step 2. It won't let you enter your account in turning on sharing on the wife's computer until you authorize your account on her computer.

    So, authorize your account on her computer and THEN turn on sharing on her computer using your account name and password.
    09-18-2009 05:53 AM
  22. Ipheuria's Avatar
    yep worked perfectly and took me 3 or 4 minutes so once you actually do it, it's so simple.

    So as obee and JON-a-Roll have said I followed these steps on my GF's laptop and I have Mac and she has Windows so it doesn't matter at all, have my laptop on with Itunes open

    On her laptop
    1. under preferences > sharing tab, select "share entire library" on both computers

    2. Authorize my account on her computer (authorize her account on yours, if you want her apps, etc.) if you are using windows, it is under store > authorize computer(Mac too)

    3. turn on home sharing for both computers. used my username for both computers for home sharing.

    Bonus when you turn on home sharing in the right pane at the bottom if you click Options/Settings you can check all the things you want to auto transfer new purchases.
    09-18-2009 08:29 AM
  23. CYaris's Avatar
    That is exactly what I did, and still no dice.

    I am going to try again later.
    09-18-2009 09:46 AM
  24. CYaris's Avatar
    Well, try later, I did. I started itunes on mine, then hers, and lo and behold, everything showed up on her computer, almost instantly. I did nothing different. It just worked.

    Excellent.

    Thanks to everyone who posted the steps here.
    09-18-2009 01:15 PM
  25. Ipheuria's Avatar
    Glad you got it sorted If you have a huge library it may just have needed time to open everything up. Also you know how things work on computers sometimes you need a little reboot of either the computer or the program to finalize settings and get it working.
    09-18-2009 02:41 PM
LINK TO POST COPIED TO CLIPBOARD