1. Microcosmos's Avatar
    Is anyone else out there experiencing trouble with their iPhone dock not charging? My 2G iPhone and dock worked fine together and charged from the USB slot on my computer, but my 3GS, with the same USB slot and an Apple brand dock, won't charge! I waited until 3.1 hoping in vain that the update would fix the strange lack of function.

    Any ideas? Am I the only one experiencing this? Thanks for reading my little tirade! I appreciate any help or input!
    09-10-2009 12:00 AM
  2. dannyleeuk's Avatar
    Is it an iPhone or an old iPod dock? I had the issue and I used the iPod dock itself but plugged my iPhone charger into the back of it. The old iPod docks/chargers had firewire cable chargers which the iPhone doesn't support, I think its something to do with the lack of the pins on the connector.

    I have an iPhone 3G btw
    09-10-2009 08:06 AM
  3. Microcosmos's Avatar
    It's an iPhone dock, designed to work with the 3G/3GS. I'm wondering why the thing doesn't work for anything but syncing.
    09-11-2009 12:20 AM
  4. wsaund#IM's Avatar
    It's an iPhone dock, designed to work with the 3G/3GS. I'm wondering why the thing doesn't work for anything but syncing.
    Mine charges for 3GS. You might of gotten a bad one.
    09-11-2009 08:35 AM
  5. galactica2001's Avatar
    I had a similar issue with my after market docking station. I had it on my desk connected directly to the back of my server computer and it would charge fine. I moved the server computer across the room and added a USB extension cable and it would sync, but stopped charging. USB provides 5VDC if I remember correctly. Most docking stations have what looks like the normal sync cable that go from the doc itself to the back of the computer. If you are using an extension cable you may be having the same issue I did. The other issue may be if your using a USB 1.1 or 2.0 port.

    If you can, disconnect the Sync Cable from the back of the Dock and connect it directly to the phone and see if you can charge. If you can then the issue is with the Dock itself and it is either not designed for the 3GS or could be broken. Since it is apple's device I would check with them on that.
    09-11-2009 09:43 AM
  6. Microcosmos's Avatar
    Oh poo. I was hoping my issue was universal and therefore, would have a universal fix! My Apple iPhone USB cable is connected directly to my 2.0 USB port on my computer (same as my 2G was) without any extensions. If I plug the USB cable directly into the phone it won't charge either. However, the phone charges fine in my Bose music speaker thingy (thank goodness!) or if I plug the USB directly into a wall outlet. Which is why I'm stumped. I definitely don't feel like driving all the way to the nearest (50 miles away) Apple store, though I may troubleshoot with Apple customer service over the phone.... Or I may just live with it. Seems silly to have a dock that won't charge my phone though.
    09-11-2009 04:39 PM
  7. Microcosmos's Avatar
    Hmmm. I called Apple tech support and the guy said to switch USB ports. I hadn't tried that because I didn't see the point. Of course, it worked!
    09-12-2009 04:56 PM
  8. alex.shimp's Avatar
    I did have once an issue where none of my usb ports would recognize anything and i had to restore my computer to new and start over
    09-12-2009 04:59 PM
  9. GMJeff's Avatar
    You were apparently not using a root hub USB port, but rather a port off of the root hub port. All USB ports offer 5vDC that powers the bus and all devices attached to it, but the primary ports have a full 5vDC charge at full 200 mA.

    Imagine a garden hose. Add a pressure nozzle (bus terminator) on the end, and turn the water on. Now about every 6 inches or so down the length of the hose, poke a 1/8th inch hole (USB device) in the hose. Keep poking until you have 122 (theoretical limit of USB devices on a bus) holes in the hose. Water will be squirting everywhere. The theoretical pressure (amperage) at the nozel should now be miniscule, as the water pressure is leaking out of the hose at all of the small holes. The volume of water (voltage) is reduced as the hose is leaking, but the pressure at the hosebib (root hub) is still constant. So, even after one hole, the pressure is less.

    This is what allows USB to daisy chain numerous devices. As long as they all draw miniscule amounts of power, they are all bus powered. Larger devices like printers, hard drives require the whole 5vDC 200mA or more to run (usually 12vDC or so). That is why they usually have their own power adapters. Phones in general can charge from a USB port, but it takes longer as they are charging on 5vDC 200mA instead of 5vDC 1A or so.
    Last edited by Jevangil; 09-13-2009 at 02:27 AM.
    09-13-2009 02:04 AM
  10. Microcosmos's Avatar
    Thanks Jevangil! I never looked at it that way, it makes sense now though.
    09-14-2009 11:31 PM
  11. claidheamdanns's Avatar
    I am getting the exact same thing at work. It will charge on the car charger, but not when plugged into the Mac -- no charge, no sync. I brought the car charger inside and plugged it into the Mac -- still nothing.

    I tried restarting the phone. Nothing, but it's stuck on "Searching..." for network. This was a soft reboot (just turning the phone off manually, and turning it back on).

    Trying a hard reboot now (holding home and power until phone cycles off, and then comes back to the Apple screen).

    Okay, great! now the phone is not coming back up at all -- it has been stuck on the Apple screen for about 10 minutes now!

    --

    Okay, it finally came back up, it can see the AT&T network, but it still will not sync or charge while plugged into the Mac.

    Message was edited by: Claidheamdanns, to remark that the phone finally booted back up, after about 10 minutes.

    ----

    Okay, I finally got a solution that worked. I downloaded the latest version of AppleJack, a free utility that does a deep clean on your Mac, repairing preferences and the like, better than any other utility I've used.

    You must use it in Single User UNIX mode, but this is no reason to fear it. Just hold down Command+S after the gong, when you reboot your computer. When you start seeing white text on a black background, you can let go. When the text stops scrolling, type this command at the prompt:

    applejack auto restart

    and hit the return key.

    This tells AppleJack to run all it's routines automatically, and then reboot your Mac in OS X. It can take a little while to do it's repairs if you have a big drive. It took about 15 min. on my 500GB drive.

    --

    When it completed its tasks and rebooted, I plugged the iPhone into it's doc and it now works like a charm, syncing as we speak, and charging!
    09-25-2009 04:15 PM
LINK TO POST COPIED TO CLIPBOARD