1. rob90262's Avatar
    So in the last couple days when I try to send and email or pic through email it says error has occured cannot sen message, then after a few trys and angry moments it will send it. Is this a hardware issue or phone and what should I do I was thinking about deleting my accounts then putting then restoring
    08-11-2009 12:27 PM
  2. Jeremy's Avatar
    Need more information to help you out. What kind of email are you using? Yahoo, Gmail, MobileMe, Exchange, etc... ?
    08-11-2009 01:26 PM
  3. Skywalker's Avatar
    I get this problem when my wifi is weak or when the phone wants to connect to a city wide wifi account where a password is needed once you log into a web page. At this point I shut down wifi and go the slow rout.
    08-11-2009 02:53 PM
  4. big9erfan's Avatar
    Also, try a full restart of the phone ( holding home and power until the apple logo shows up ).
    08-11-2009 03:06 PM
  5. rob90262's Avatar
    Using yahoo sorry
    08-11-2009 03:51 PM
  6. anon(153966)'s Avatar
    Did a power cycle of the iPhone help?

    Did you try sending just a plain text email? Did that work? Maybe there is an issue with the attachment...

    Did you try turning on wifi, and trying the email that way?

    Did you try removing the email account, and re-adding it?

    Do you have another email account you can test on the device?
    08-11-2009 03:54 PM
  7. Ipheuria's Avatar
    All those are good but to determine if it's the device or connection try sending the message from a laptop or PC if you continue to have a problem. So you can rule out any problems with the email account or attachment. Then send the same message on the phone and see what happens.
    08-11-2009 04:21 PM
LINK TO POST COPIED TO CLIPBOARD