1. VagrantHarmonist's Avatar
    I was just curious how many have had the glitch in 3.0 where you have the wrong icon on an app. I know this has been discussed before but considering this happens every time i hard reset my phone to at least one icon and the only real solution is sitting through the 40 minute - hour long restore process, I was wondering if it was even worth calling apple and telling them or just be patient for the next update? Am I just being fussy? Any response would be welcome and if this is deemed as a repeat post, feel free to close it. Thank you for your time.
    08-06-2009 07:54 PM
  2. nickpav's Avatar
    i had it when i got my 3gs. then i updated to 3.0.1 and it went away. i know it wasnt addressed in the update, but im 99% sure it went away because my phone was restored in the update process
    08-06-2009 09:04 PM
  3. VagrantHarmonist's Avatar
    Unfortunately the only reason it went away was cuz the phone had restored...it will come back I guarantee it. It makes me a sad panda.
    08-06-2009 09:12 PM
  4. FrankRow's Avatar
    i've had this issue before on my 3GS. What i did was connect the phone to itues, and unsync/remove the app from my phone through itunes and then reinstall the app. That worked and placed the right icons with the right apps. I didn't have to do a restore. Since then everything has been fine, but i am a little hesitant to do another restart b/c it may happen again. But the fix was easy, just uninstall/reinstall the app through itunes. Hope this helps.
    08-07-2009 11:16 AM
  5. VagrantHarmonist's Avatar
    i've had this issue before on my 3GS. What i did was connect the phone to itues, and unsync/remove the app from my phone through itunes and then reinstall the app. That worked and placed the right icons with the right apps. I didn't have to do a restore. Since then everything has been fine, but i am a little hesitant to do another restart b/c it may happen again. But the fix was easy, just uninstall/reinstall the app through itunes. Hope this helps.
    awesome!! If it happens again I will definitely try that!! So much better than a restore ha ha!! U rock!
    08-07-2009 11:21 AM
  6. Rich's Avatar
    and unsync/remove the app from my phone through itunes and then reinstall the app. That worked and placed the right icons with the right apps.
    I'll second that. I did the same thing a few weeks ago and it resolved my mixed up icons as well. No restored needed.
    08-07-2009 01:01 PM
  7. big9erfan's Avatar
    Had the problem last night ( and a few times before ) deleting it off the phone and resyncing ( usually ) fixes ti straight away.
    08-07-2009 01:03 PM
LINK TO POST COPIED TO CLIPBOARD