1. dman's Avatar
    I just got a 3GS. On my 3G, I had some custom ringtones using the M4R hack. After upgrading, my ringtones are unavailable. In iTunes, they show up as being on my phone and in my iTunes library, however, I can't access them from on my phone. Did Apple finally fix this, or am I doing something wrong?

    Thanks.
    07-21-2009 11:29 AM
  2. VagrantHarmonist's Avatar
    Have u tried to "delete" them from your phone through itunes and readding them?
    07-21-2009 11:46 AM
  3. Jeremy's Avatar
    I just got a 3GS. On my 3G, I had some custom ringtones using the M4R hack. After upgrading, my ringtones are unavailable. In iTunes, they show up as being on my phone and in my iTunes library, however, I can't access them from on my phone. Did Apple finally fix this, or am I doing something wrong?

    Thanks.
    Try syncing again and make sure all of the ringtones are checked off within iTunes. The m4r trick still works fine.
    07-21-2009 11:57 AM
  4. dman's Avatar
    I haven't tried deleting it from the phone, how do I do that?

    As for checking it off, yes I'm sure it is. I told it to sync all ringtones and when I go to the "Ringtones" folder on my iPhone (from within iTunes) it lists the ringtone. It's just not available within the Sounds settings.
    07-21-2009 12:01 PM
  5. VagrantHarmonist's Avatar
    I haven't tried deleting it from the phone, how do I do that?

    As for checking it off, yes I'm sure it is. I told it to sync all ringtones and when I go to the "Ringtones" folder on my iPhone (from within iTunes) it lists the ringtone. It's just not available within the Sounds settings.
    you just go to the ringtones "playlist" under ur iphone in the left column and then select them all and hit delete. Then try selecting the ones that are in your ringtones "playlist" above your iphone (the ringtones you've made) and drag them to your iphone. Hope that helps! ^.^
    07-21-2009 12:05 PM
  6. dman's Avatar
    you just go to the ringtones "playlist" under ur iphone in the left column and then select them all and hit delete. Then try selecting the ones that are in your ringtones "playlist" above your iphone (the ringtones you've made) and drag them to your iphone. Hope that helps! ^.^
    Pressing delete doesn't do anything. The items in the list are kind of grayed out (same with my music - though my music does work). I can't even select it. Any clue what might cause that?

    Thanks for the help!
    07-21-2009 07:40 PM
  7. dman's Avatar
    Pressing delete doesn't do anything. The items in the list are kind of grayed out (same with my music - though my music does work). I can't even select it. Any clue what might cause that?

    Thanks for the help!
    Nevermind, the problem was I needed to turn on the "manually manage my music" feature. I deleted it, and now it's working perfectly. Thanks!
    07-21-2009 08:09 PM
  8. Dipstix6996's Avatar
    Try Ctrl+Alt+Del
    07-21-2009 11:37 PM
LINK TO POST COPIED TO CLIPBOARD