1. tefloncoated's Avatar
    (it seems that) After the jailbreak my 3GS doesnt open youtube links in Safari.

    Observed behavior: Clicking a Youtube link or pasting it into Safari connects to the actual Youtube page. The video box appears, but the Play button is grayed out with a line across it.

    Note: I have the UAFaker installed, but i dont think it's related. With UAFaker ON or OFF, clicking a Youtube link still calls the Safari and opens the youtube page, only with UAFaker ON it sees it as a regular page with "older version of Flash player".

    Youtube app on its own works as expected.

    I found this link (please copy paste, as i dont have enough posts to Insert Links): forums.whirlpool.net.au/forum-replies-archive.cfm/1228189.html listing a restore as the ultimate solution.

    I also found some old (pre 3.0) link: abstractpath.com/weblog/2008/09/fixing-youtube-on-jailbreaked-202.html, suggesting deletion of %AppData%\Roaming\Apple Computer\Lockdown (on desktop) and /private/var/root/lockdown (on iPhone) directories. It doesnt apply as i dont have these on my desktop or on the iPhone.

    So before i try to restore the 3Gs and jailbreak it again, I just wanted to see if anyone else has had this problem and possibly found a solution?

    07-08-2009 04:25 PM
  2. chrstphr.ross's Avatar
    I'd try just opening a link directly after jailbreaking, before installing any apps. That way you can see if it's the jailbreak (in which case it might just be a bug) or if it's an app issue.

    I'm on 3G 3.0 jailbreak and all seems to work amazingly well for me.
    07-08-2009 04:29 PM
  3. tefloncoated's Avatar
    good point, i will do that.
    07-09-2009 08:28 AM
  4. Gumboot's Avatar
    Did you end up finding a fix for this. I posted the original post that you have linked to regarding doing a restore to fix the problem but I have the problem back again.
    07-20-2009 05:49 AM
  5. Gumboot's Avatar
    Problem solved.

    The problem is with the app Categories. If you place the Youtube app into a folder it for some reason disables Youtube links via Safari. My guess is Safari links to the Youtube app via the springboard and by removing it thinks the Youtube restriction is enable and does not allow Youtube at all.

    So to fix it you just remove the Youtube app from the folder and keep it on the springboard.
    07-20-2009 06:36 AM
  6. tefloncoated's Avatar
    Gumboot, excellent find! I left the attempts to fix that via a restore until 3.1, just wasnt that big of a deal to me. Thanks for posting it!
    07-20-2009 09:03 AM
  7. MocKKnihgT's Avatar
    Awesome find!

    I was super bumed when youtube wasn't working...but problem solved
    08-09-2009 08:07 PM
  8. wongnog's Avatar
    I've been stuck for days with this problem until a google search came across this thread. Thanks gumboot!
    02-14-2010 11:33 PM