1. talkin73's Avatar
    With OS 2.x I used to hold the power and home buttons to take a screenshot. Since upgrading to OS 3.0, following the same procedure only brings up the "slide to power off" screen. Does anyone know how to take a screenshot with a 3G running OS 3.0? Thanks for any assist.
    07-03-2009 11:40 PM
  2. Leanna Lofte's Avatar
    You're just supposed to push them quickly, not hold them down. This has always been the case. If you continue to hold them down after the "slide to power off", then the iPhone will reset.
    07-03-2009 11:44 PM
  3. Jellotime91's Avatar
    You're supposed to press them at the same time or hold the home button and tap the power button and then let go of both of them. Worked fine for me with my old 3G on 3.0zz
    07-03-2009 11:44 PM
  4. Rada's Avatar
    Mine still takes a screenshot when I press them both at the same time. I don't think this is 3.0s fault.
    07-03-2009 11:47 PM
  5. talkin73's Avatar
    Thanks to all for the prompt feedback. I think I just got confused having not done this in awhile. I just tried the quick press of both buttons and it works fine for me too. Much appreciated!
    07-04-2009 05:36 AM
  6. Tramain's Avatar
    Your screen will tun white for a second if you take a screenshot.
    07-04-2009 06:42 AM
LINK TO POST COPIED TO CLIPBOARD