1. cobra302's Avatar
    i dont know if anyone else has had any trouble with their yahoo business accts or not. i'm not on an exchange server, so i just use the normal imap, or pop accts on my iphone. we have a company website that we have yahoo business emails thru. i was able to set up the acct, receive email, and even got all my folders to show up where i could edit, move, or delete whatever messages that came in, and have it take effect on the server as well. it wasnt until today that i realized that the emails i was sending out were never getting to the recipient. the acct acted like they were sent, and i never had any error messages or anything. long story short, i did some research and found that iphones dont play well with yahoo bizmail accts. what i mean by bizmail is that the smtp reads:smtp.bizmail.yahoo.com, or pop.bizmail.yahoo.com for the incoming server. anyway, i spent some time on the phone with att, then apple. while waiting for apple, i found some information which i'll post in a sec. i explained what i found to the apple tech guy who said, hmmm, try it. i did and it worked great. i dont have the folders anymore so the "imap" functionality i suppose is gone, but thats not too big of a deal as i always store emails within outlook anyway. the main thing is that my emails are actually being sent now. here is the information i found. i just copied and pasted it here. hope maybe it helps somone.

    step 1:
    Turn Iphone on.

    step 2:
    Select settings.

    step 3:
    Select mail.

    step 4:
    Select add Account

    step 5:
    Select Other (I know that it is a yahoo mail account but just trust me)

    step 6: {Entering info into fields} Also please select POP

    Name : ie "your name"

    address : ie "your name@your domain.com"

    description : this field should auto fill with (address) but you can change it if you like.

    Host Name is pop.bizmail.yahoo.com
    User Name is ie "your name@your domain.com"
    Password is your password (same as yahoo mail password)

    Host Name is smtp.bizmail.yahoo.com
    User Name is ie "your name@your domain.com"
    Password is your password (same as yahoo mail password)

    Then Click Save at the top right of screen (scroll up if not visible)

    You will get an error message select no.

    Select Save again. You will get an error message saying that you may not be able to send or recieve email. Save anyway!!!

    Step 7:

    Select Mail from the Top Left of the screen to view your mail accounts. Select the one you just set up and saved.

    Scroll down to the bottom of the screen and select advanced.

    Here are the settings for this screen

    Deleted messages
    Remove Never>

    Incomming Settings
    use SSL set to on
    Authentication Password>
    Delete from server Never>
    Server Port 995 (this is important)

    Outgoing Settings
    Use SSL set to on
    Authentication Password>
    Server Port 465 (this is important)

    Then scroll back up and select the button at the top left (the one will your email address on it)

    Then select the button at the top left that says mail.

    Then select the button at the top left that says settings.

    Then press the home button on the face of the Iphone

    Then select mail from the menu on screen.

    Then select your email address from the list (if you have more than one email address on your phone you will have to select accounts at the top left of the screen)

    Then select your inbox and your sent folders to see your mail.

    Now do some test messages to make sure it is working.

    If you are unable to send and recieve mail go back to steps 6 and 7 and make sure you entered the information correctly.

    i also wanted to note that when i completed step six above, the acct verified, and i didnt have any problems after that. i didnt have to change any of the ports or anything, they just all showed up good.
    06-29-2009 02:29 PM
  2. SHEDGES's Avatar
    Cobra, I had the same problem with my Yahoo BizMail account. I followed your steps and everything seems to be working great. Thanks for the post!!
    07-14-2009 06:31 PM